079.1 homeassistant iOS : this integration has no devices?


I have no ios: set in configuration.yaml, since I expected this integration to not need that. Should it still be there to show all iOS devices?

it clearly states : only configuration via the integration:

I have the same issue.
I’ve tried adding iOS: to config file, but same result.

fwiw, It displays the same when I click on any of my Zones, all of which Ive manually entered in the integration pages, so they should be there…

I am seeing the same thing. I cannot figure out the problem. I started with a fresh install of 0.79.2 and uninstalling/reinstalling the iOS app. This all worked fine on 0.78 before I messed up my entire configuration and had to start over.

UPDATE: So I was able to figure this out. I made a couple changes that got it working again.

  1. Add an api_password under your http configuration. See documentation
  2. Add an auth_provider of type legacy_api_password. See documentation

Once I did that my iOS app started functioning normally. Hope this helps someone.

Thank you.
Adding the api password solved.
However I had to leave iOS: in the config file.

what exactly did this solve?
connect the iOS app and have it show HomeAssistant, or have the integrations snow the iOS sensors?

I have no problem using the app on the Hassos instance, but in the integration no devices are listed.
Adding legacy_api_password must be incorrect here, since I have a completely fresh install, and fully rely on the new authentication process?

Do we need an http password, next to this new authentication process, where each user has its own id and password? Cant be right can it?

yep… it doesn’t make sense to me either, but it seems the only workaround at the moment.
Even adding ios: in the configuration file should not be necessary but HA has discovered my devices only this way.
Maybe this will be fixed in future updates.

not quite yet here:

2018-10-04 18:06:33 ERROR (SyncWorker_15) [homeassistant.components.notify.ios] The notify.ios platform was loaded but no devices exist! Please check the documentation at https://home-assistant.io/ecosystem/ios/notifications/ for more information

anything else you’ve set for HA to recognize your devices?


next to adding ios: in the configuration.yaml, ive also copied the hidden .ios.conf from my other Hassio instance to the new setup, et voila, all my iOS devices are displayed…

no auth_provider, or api_password needed (a least not for this integration )

need help. Well mine displays the data from my iphone. But it does not update … I put to load does not exhibit that it is loading. Does not update% battery. What can I do to force this update more often.

these sensors are notoriously unreliable. Never use them in automations your system depends on. Not sure if its HA or Apple…