2021.1: Happy New Year!

Wow, did you really just fix something I encountered 3 days ago?

My resolution is to make HA useful to my family. Right now, there is essentially one switch they care about, and I’m not even sure what I’ll do with all the others devices that were discovered!

EDIT2:
Ok I have no idea what the hell is going on, but it’s working now. I needed to reboot several times and for whatever reason, for MY instance, the port is required in the neato application

I posted over in /r/homeassistant also, but may get more traction here since this is so new:

I followed the process to create the new auth method (oath2). However, when I try to reconfigure the integration, I get an error when it links to neato’s developer site: Client authentication failed due to an unknown client, no client authentication included, or unsupported authentication method.

I found in the url that it’s trying to access, it’s including my url and port, but this is not defined in the neato developer network.

I have the redirect URI configured as https://example.duckdns.org/auth/external/callback, but in the url, it’s returning https://example.duckdns.org:8123/auth/external/callback.

If I just navigate directly to https://example.duckdns.org/auth/external/callback, the page doesn’t load (chrome says refuses to connect). If I navigate to https://example.duckdns.org:8123/auth/external/callback, the page says: Missing code or state parameter in https://example.duckdns.org:8123/auth/external/callback

Also, in my config file, my external url is:

homeassistant:
external_url: https://example.duckdns.org
internal_url: http://myInternalIP:8123

What have I done wrong? I added the port in neato’s redirect URI and removed the port in the address bar to test, but no change.

EDIT: After a reboot, I get “The redirect URI is not valid” on the neato dev page. I found the 8123 is in the url, so I removed it and it’s progressed to the next page to “Authorize my neato account.” However, when I do, the page no longer resolves and chrome says, “refused to connect.”

Then I added the :8123 in the neato dev account and retested and now it resolves when I “Reconfigure” neato, but then when I click Authorize, it fails and says 500 Internal Server Error.

I also trabbed into the NEATO breaking change. I use HA Container locally. Up to now my installation uses http only. If I switch to HTTPS for Homeassistant, all of my additional software packages like Node Red, Tasmoadmin, ESPHome, Grafana, which are also setup locally using http, can’t be used any longer (using the iframe capabillity on the left side). In addtion to that my camera streams from frigate (debug view with detection information), which are also embedded as a iframe in lovelace are also broken.

My questions:

  • Is there an easy configuration possible to use all of them together?
  • Is Homeassistant capable to be available through http and https at the same time (two endpoints)? So then the authentication logic could be run on the secure endpoint then by default?

I think you should be able to setup a reverse proxy and make HA available externally through https. But don’t know if this is necessary or if there is an easier way.

1 Like

i am getting the exact same error

tried again today an problems are gone…

I did this:

pip install idna==2.2

After install I did a check again:

starting version 3.2.9
[11:22:10] INFO: Update udev information
[cont-init.d] udev.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[11:22:10] INFO: Setup udev devices
[11:22:11] INFO: Don't worry, this temporary installation is not overwriting your current one.
[11:22:11] INFO: Installing Home Assistant: latest...
[11:22:11] INFO: Please be patient, this might take a few minutes...
[11:23:18] INFO: Installed Home Assistant 2021.1.0
[11:23:18] INFO: Making a copy of your configuration for checking...
[11:23:19] INFO: Checking your configuration against this version...
[11:29:28] INFO: Configuration check finished - no error found! :)
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Everything seems ok. I do a second check if it gives me same result than backup my system and then do the upgrade

Does it make sense to remove the custom component and use the integration of HA itself now?

It’s a pity the GoFundMe platform doesn’t support PayPal. It would have made me able to contribute to the fundraising.

That would be the ideal way to go, yes. I intend to keep the beta component repo and use that when testing new features, before pushing them to HA. Once I’m there, it boils down to if you want to test new features or not.

1 Like

Even I never had contact with @Villhellm, my condolences to his family and friends. :cry:
He was way too young.

Second most important action this year:

Happy new year to the core team and all contributors of Home Assistant.
You’re doing a great job, have an enormous engagement, you’re always be patient when users are neewbees or have blackouts - you’re simply great. This community is the best example of respectful teamwork around the complete world. It works!
Stay healthy, have fun and keep up this great work.
Thanks a lot!!

3 Likes

Happy new year to you all indeed. And what an immense loss for @Villhellm. Unimaginable. My thoughts are with his family.

Adding to the world in its current turmoil, one of my resolutions for HA would be to finally get Hue lights to flash long in a color (red for alarm…!)
Seems not to be possible, and really feel it should be.

Of course, will keep occupying this community and seek and offer assistance when- and wherever possible.
Cheers to you all!

btw, buttery smooth update it was, yet again. Thanks.

I still cannot readd the AppleTV.
I uninstalled the HACS version and tried again with official integration, but the same error appears.
" A problem occurred while pairing protocol MRP . It will be ignored."

Any idea?

Guys i really love you, this project is born in the right way and evolving in a semi perfect solution, 30 years using internet, unix system, networking and server appliance i never see nothing growing fast and stable like hass :partying_face:

1 Like

This thread might help to achieve your goal :grinning:

thanks. however, that’s for Deconz, and I should maybe have added Id like to use the Hue bridge.
btw, I did give your suggestion a go, but couldn’t get a single Philips Hue White and Color Ambiance E27 light to be found by the photon integration…

Is there a reason 2021.1 is not showing up correctly on my HassOS? I did the update and this is what I have in the supervisor now. Also I heard OS 5.10 is out but have not been notified of upgrade.

Try a Ctrl + F5 browser refresh. If that does not change things…

You started the update, but it looks like it did not complete and was rolled back to 2020.12.7

Reload the supervisor (bottom left of the supervisor card) and see if the newest version updates.</>

EdIt: Actually looking at my supervisor card I see 2020.12.7 as the newest version too, despite having an alert for 2021.1 on my supervisor dashboard.

What does your config / info menu show?

Your update probably did work and there is something amiss in the supervisor display.

The latest version of supervisor is 2020.12.7. The latest version of core is 2021.1.0.

https://version.home-assistant.io/stable.json

2 Likes

Any chance we could get the conference videos viewable on PeerTube?

Specifically, conf.tube seems like it would be an instance that would be perfect for this, with unlimited quota for videos of conferences from open source projects. You can even set it up to automatically mirror from your YouTube account, so just 15 minutes of setup takes care of the whole thing.

Heck, I’d be happy to set it up myself with permission from the HA team to republish the videos on your behalf.