2021.1: Happy New Year!

Doh! :man_facepalming:

1 Like

What’s in the log?

Did you reset the bulbs before trying to pair them? I have no problems with the E27 Color and White feom Philips.

I have added

logger:
  logs:
    pyatv: debug
    apple_tv: debug

to the conf but no details regarding apple tv :-/

Right, the error means that Home Assistant failed to connect to the device. First, did you try to reboot the Apple TV? Helps sometimes. Also, do you have any kind of special set up with VLANs and MDNS repeaters?

Just tried a reboot, but no luck.
No special setup, no vlan, same subnet.

Condolences to @Villhellm … Thank you for the GoFundMe link as well.

An alternative would be to setup Hyperion (either running as a Rpi image with Hyperbian or in Docker). It can control Hue lights and can add a hell of a lot of effects (effect_list: Atomic swirl, Blue mood blobs, Breath, Candle, Christmas, Cinema brighten lights, Cinema dim lights, Cold mood blobs, Collision, Color traces, Double swirl, Fire, Flags Germany/Sweden, Full color mood blobs, Green mood blobs, Knight rider, Led Test, Light clock, Lights, Notify blue, Pac-Man, Plasma, Police Lights Single, Police Lights Solid, Rainbow mood, Rainbow swirl, Rainbow swirl fast, Random, Red mood blobs, Sea waves, Snake, Sparks, Strobe red, Strobe white, System Shutdown, Trails, Trails color, Warm mood blobs, Waves with Color, X-Mas)

You can also define your effects, based on the templates above and they’re loaded into HA.

I have one instance running on Rpi2 connected to a digital led strip (for a Hue Sync Box clone) and another on Docker controlling a set of Hues that can either function independently or act as a receiver for the Rpi2 instance.

For those missing the AVRI integration go to the Afvalbeheer integration in HACS as that one has support for the new platform AVRI is using.
https://github.com/pippyn/Home-Assistant-Sensor-Afvalbeheer

@Petrica, @M1ke and others:

Suddenly managed to do it, HUE lights flashing in color! One needs to first turn_on the light, and then this can be entered in the service_call

flash: long
entity_id: light.kayon
color_name: red

explained a bit more here, so won’t cross poster any further:

some scripts:

  lights_flash_color:
    alias: Flash lights in color
    mode: restart
    icon: mdi:alarm-light
    sequence:
      - service: light.turn_on
        data:
          entity_id: light.flash_lights
          color_name: >
            {{states('input_select.select_flash_color')|lower}}
      - repeat:
          sequence:
            service: script.lights_flash_on_color
          until:
            condition: state
            entity_id: input_boolean.flash_color
            state: 'off'

  lights_flash_on_color:
    mode: restart
    sequence:
      - service: light.turn_on
        data:
          entity_id: light.flash_lights
          color_name: >
            {{states('input_select.select_flash_color')|lower}}
          flash: long
      - delay:
          seconds: 15 # is the time a regular flash cycle takes, 1 flash per second

  lights_flash_off_color:
    alias: Stop Flash lights in color
    mode: restart
    icon: mdi:alarm-light-outline
    sequence:
      - service: script.turn_off
        entity_id: script.lights_flash_color, script.lights_flash_on_color
      - service: light.turn_on
        data:
          entity_id: light.flash_lights
          profile: relax # reset lights to a non alarmed color, for next turn_on ;-)
      - service: light.turn_off
        entity_id: light.flash_lights

and a few inputs:

input_boolean:
  flash_color:
    name: Flash color

input_select:
  select_flash_color:
    icon: mdi:palette
    name: Select flash color
    options:
      - Red
      - Green
      - Blue
      - Yellow
      - Purple
      - Orange
      - White

light.flash_lights is a light group of selected lights being able to be set in colors.
make into this Lovelace bare setup:

  - type: entities
    title: Flash color
    entities:
      - entity: input_boolean.flash_color
        secondary_info: last-changed
      - input_select.select_color
      - entity: script.lights_flash_color
        name: Flash lights in color
        action_name: Flash
      - entity: script.lights_flash_off_color
        name: Stop Flash lights in color
        action_name: Stop

and some fiddling in the customizations:

homeassistant:
  customize:
    input_select.select_flash_color:
      templates:
        icon_color: >
          return state.toLowerCase();

    input_boolean.flash_color:
      templates: &flash
        icon: >
          if (state == 'on') return 'mdi:alarm-light';
          return 'mdi:alarm-light-outline';
        icon_color: >
          if (state == 'on') return entities['input_select.select_flash_color'].state.toLowerCase();
          return 'steelblue';

    script.lights_flash_color:
      templates: *flash

simply keeps flashing away :slight_smile: yeah.

1 Like

Hi all ! Happy new year !

First time I cannot update Home assistant on RPI3b+

21-01-08 08:49:04 ERROR (SyncWorker_1) [supervisor.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:2021.1.0 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2021.1.0&fromImage=homeassistant%2Fraspberrypi3-homeassistant: Internal Server Error (“Get “https://registry-1.docker.io/v2/”: dial tcp: lookup registry-1.docker.io: no such host”).

I tried to reload then restart supervisor. I also tried to reboot HA OS 5.9 but no luck.

Any idea to fix this?

I’m not sure. But there were known bugs of OS 5.8 and may be 5.9.
Maybe these bugs are related to your problem.

As am I. This might might shine some light on it? Is it nothing? Has anyone tried it?

I came here to read about all the cool new things for this release and then read the sad news. Even though I didn’t know @Villhellm I whish his family, friends and everyone he knew all the best in this difficult time. I guess it doesn’t even really matter what happened, 27 is not a good age to go.

I’m having the same issue, did you resolve it?

Not yet :grimacing:

Neato failed with the error: Error setting up entry Configuration.yaml for neato.

I first deleted all prior vacuum entities that were created from the older username/password config to ensure I was starting fresh. Restarted HA. Created the new configuration with client_id and secret. Restarted HA. The “new integration” popped up, properly connected and said successful. It creates 1 device with zero entities (so I can’t do anything). Here are the logs:

Logger: homeassistant.config_entries
Source: components/neato/__init__.py:140
First occurred: 2:10:48 PM (1 occurrences)
Last logged: 2:10:48 PM

Error setting up entry Configuration.yaml for neato
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 236, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/usr/src/homeassistant/homeassistant/components/neato/__init__.py", line 99, in async_setup_entry
    await hass.async_add_executor_job(hub.update_robots)
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/util/__init__.py", line 239, in wrapper
    result = method(*args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/components/neato/__init__.py", line 140, in update_robots
    self._hass.data[NEATO_ROBOTS] = self.my_neato.robots
  File "/usr/local/lib/python3.8/site-packages/pybotvac/account.py", line 41, in robots
    self.refresh_robots()
  File "/usr/local/lib/python3.8/site-packages/pybotvac/account.py", line 78, in refresh_robots
    r = Robot(
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 58, in __init__
    if self.service_version not in SUPPORTED_SERVICES:
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 284, in service_version
    return self.available_services["houseCleaning"]
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 280, in available_services
    return self.state["availableServices"]
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 276, in state
    return self.get_robot_state().json()
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 229, in get_robot_state
    return self._message({"reqId": "1", "cmd": "getRobotState"})
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 81, in _message
    response = requests.post(
  File "/usr/local/lib/python3.8/site-packages/requests/api.py", line 119, in post
    return request('post', url, data=data, json=json, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/requests/api.py", line 61, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/requests/sessions.py", line 528, in request
    prep = self.prepare_request(req)
  File "/usr/local/lib/python3.8/site-packages/requests/sessions.py", line 456, in prepare_request
    p.prepare(
  File "/usr/local/lib/python3.8/site-packages/requests/models.py", line 320, in prepare
    self.prepare_auth(auth, url)
  File "/usr/local/lib/python3.8/site-packages/requests/models.py", line 551, in prepare_auth
    r = auth(self)
  File "/usr/local/lib/python3.8/site-packages/pybotvac/robot.py", line 313, in __call__
    key=self.secret.encode("utf8"),
AttributeError: 'NoneType' object has no attribute 'encode'

Tehre has been some issues with Neatos API in returning invalid data. Please check the neato app and possibly reconnect the vacuum and then restart HA and it should fix this issue. There is also an open issue on github.

Finally!

HA OS update to 5.10 fix the issue.

Hope this help

I just updated to the latest version for 2021.1 and my Supervisor screen is still reporting:

Version
2020.12.7

Newest Version
2020.12.7

This has been the case ever since, well, 2020.12.7…

Should this not be reporting the 2021.1.x versions??