2021.10.0: Z-Wave S2 support, Tuya, secure ESPHome and 400 new icons

You’re giving NO useful data.

Before 2021.10.0:
Entity: sensor.shelly_shem_XXXXXX_total_consumption
unit_of_measurement: kWh
device_class: energy

That is visible in Energy Dashboard

After 2021.10.0:
Entity: sensor.shelly_shem_XXXXXX_total_consumption
unit_of_measurement: kWh
device_class: power

That is NOT visible in Energy Dashboard
This is all I was saying.

I asked what devices you were using?

I have this as well, but since 2021.9 I think. . I assume you are using white theme ? The icon is showing the colour of the bulb, ie cold white. If you change it to warmer, or a colour, it shows up. I think there was an issue on GitHub.

1 Like

Thanks @Holdestmade solved it by changing the colortemp.

Only the other weird issue stays ( the moustache on the badge) I called it a moustache but it is the person icon. Just looks like a moustache over the avatars.

Give some detail! No one can diagnose problems without context,

Disabling zeroconf the use of the cpu returns to normal. Unfortunately it is an essential service for my use of home assisatnt, I tried to debug with py-spy, but honestly I am not able to identify the problem.

A tip for those having issues with adding Z-Wave devices using S2: keep removing and re-adding the devices until it works.
I kept re-adding my Fibaro Roller Shutter 3 and sometimes, I got just “blank node” as device, sometimes I got full device but with a warning message that it was not added securely. After few tries, the device was correctly added securely.

I already had Tuya integration configured in my HASSIO. With update the existing Tuya integration stopped working and I cannot even delete it (if I try to delete it from Integrations it does nothing). I also tried to disable it first and then reboot, but I still can’t remove it… I’m a bit disappointed.
Anyone has a solution to remove manually?

Thanks

I sincerely feel sorry for the users who have a lot of Tuya devices. Personally, I only gave me one device and I removed it after constant problems. I will never buy a Tuya device again.

1 Like

There is no need, if you enable the different subnet in the HA network config then TPLink can now discover them in that other subnet.

Yesterday couldn’t turn on one of my tuya lights, today one of them isn’t turned off at sunrise… Getting frustrated with these problems.

This is not workable. I can turn on and off the lights in the Tuya app, and at the same time HA won’t work with those lights or put them on/off like 3 minutes later…

Worst “integration” ever?

1 Like

I have finally identified the problem.
Daikin AC integration coupled with zeroconf causes high CPU usage. By eliminating the integration and leaving zeroconf active, the use of the cpu returns to be normal.
After disabling integration, an HA reboot is required. By adding the integration again, the CPU remains at normal values. When HA is restarted, the problem recurs and it is necessary to disable integration again, restart HA and re-enable integration.

anyone else experience issues with the materialdesign icons?
I have several Lovelace dashboards but after upgrading from 2021.9.7 to 2021.10.1 several of my icons do not show anymore. This happens on all dashboards and multiple, almost all, icons.
I only see 1 notice in the logfile about

As per release notes MDI was updated to v6 in this release, so they could have been renamed (as mentione in the log)
I also think brand icons have been dropped from MDI

then check the breaking change part for MDI as it will list those changed or dropped

Have you tried clearing your browser cache and refreshing the page?

Yeah, thank you for this, it fixed my issue, all my icons are back. Will remember this one for the future :slight_smile:

Trying to setup new Tuya integration. It returns me:

Login error (1109): param is illegal ,please check it

Cannot find 1109 in this forum, so trying to ask for help this way. Did any other jump into same troubles?

I think there is an issue with the frontend version released in 2021.10.1

Try adding an alarm panel card. No icon for the badge.

Try adding a badge to a view. No badge.

1 Like

Alarm panel immediately shows error:

Invalid configuration
type: alarm-panel
states:
  - arm_home
  - arm_away
entity: ''

Honestly, I never used badges, so I cannot recognize any difference.