2021.2: Z-Wave... JS!

Finally!!! THANK YOU JS!!! my trouble are over! I love you all!!!

I guess it’s just me. Everyone else seems ecstatic about 2012.2. I, however, have to sleep on the couch and hope my wife doesn’t kill me and go back a stupid-house

I am running into an issue on Home Assistant Blue where I get the following errors after the upgrade:

Error during connection setup: (sqlite3.DatabaseError) database disk image is malformed [SQL: CREATE INDEX ix_states_old_state_id ON states (old_state_id)] (Background on this error at: http://sqlalche.me/e/13/4xp6) (retrying in 3 seconds)
5:54:06 PM – recorder (ERROR) - message first occurred at 5:53:30 PM and shows up 10 times
Error executing query: (sqlite3.DatabaseError) database disk image is malformed [SQL: CREATE INDEX ix_states_old_state_id ON states (old_state_id)] (Background on this error at: http://sqlalche.me/e/13/4xp6)
5:54:06 PM – recorder (ERROR) - message first occurred at 5:53:30 PM and shows up 10 times
Adding index `ix_states_old_state_id` to database. Note: this can take several minutes on large databases and slow computers. Please be patient!
5:54:05 PM – recorder (WARNING) - message first occurred at 5:53:29 PM and shows up 10 times
Database is about to upgrade. Schema version: 10
5:54:05 PM – recorder (WARNING) - message first occurred at 5:53:29 PM and shows up 10 times

I waited, tried reloading, rebooting, removing the db (typical provided solutions). I then decided to just restore the snapshot but that is not working either. I get this error:

21-02-03 23:59:25 WARNING (MainThread) [supervisor.jobs] 'SnapshotManager.do_restore_partial' blocked from execution, system is not running

If I try to restart Supervisor I get the following:

21-02-03 23:58:40 WARNING (MainThread) [supervisor.jobs] 'Supervisor.restart' blocked from execution, system is not running

Any suggestions? Command line snapshot restore doesnt work either (created/downloaded a snapshot just before upgrade). This is on the Home Assistant Blue. Thank you.
Edit: Supervisor seemed completely dead but I was able to join the Beta channel and upgrade to that. That allowed Supervisor and snapshots to work. I was then able to restore the snapshot from right before I upgraded to 2021.2.0. Then I went back to the stable version of Supervisor. Not sure how or why but recorder and history were missing from the latest snapshot. That may somehow have caused the entire issue with the update to 2021.2.0 core but I am not sure about one way or the other.

1 Like

Is there any work being done or though for xiaomi devices integration. But a functioning one, not one where you need to find a non existing token?
There is so many devices of xiaomi :frowning:

To go back you should be able to just restore from backup. It sounds like your zwave config file might got corrupted. This happened to me a few times. If you have a backup try to first swap zwave config file its in your config folder something like zwcfg_XXXX.xml .

The other issue what might have happend is the usb path device name changed. In your main config under zwave for usb_path make sure you use full path like “/dev/serial/by-id/usb-0658_0200-if00” instead of something like “/dev/ttyACM0” . More on how to get that usb path is here

Hope this helps.

It looks like the format of zwave network key might have changed for zwave js.

Excellent update again, no issues to report at this stage.

This update broke my system. I used the addon ‘Check home assistant configuration,’ and it reported no errors. However, now it is stuck on rebooting waiting for HA to finish restarting. I reboot the host, and the same thing. I cannot restore back to previous version, because
ERROR (MainThread) [supervisor.utils] Can't execute restart while a task is in progress

There are at least three places to check logs, so where do I start?

UPDATE: One of my addons (that I wasn’t really using anyway) docker container never started. I uninstalled it, and everything started up fine. I have (maybe now fixed) some issues with CT100 Zwave thermostat. I couldn’t set the temperature from lovelace, but could from control UI.

I have to say that the new control UI in Zwave JS 2 MQTT is SOOO much better than the OZW one. The old one looks like a barely functional Windows 95 window. The new one is really powerful, and nicely laid out. Kudos to the developers.

1 Like

Details on how to enable support for pico remotes with Lutron caseta are here

1 Like

This team is just bloomin’ awesome - thanks for all the hard work - looking forward to DHCP Discovery, deCONZ logging, and seeing Tasmota is out of beta give me confidence to sever some server ties


Since the installation of this version my memory usage has gone to 80% instead of 30% and nothing has changed in the installation only this core update are more people affected by this?

I have tried restoring from backup and my zwcfg looks fine. I restored the entire config directory structure, which I make a backup of every night, but HA still is 2021.2 and no problems are solved.
How can I go back to 2021.1.5? I’m on a NUC, debian 10, supervised

I had the same “issue”.
I had to configure it via the UI now.
I gave the user full permission, then configured the integration and then removed the permission from the user.
Seems to work fine.

But of cause, all my automations don’t work anymore…

Did I miss the information about this change anywhere?

Unfortunately with this version, my Foscam´s are not working anymore. I use the Foscam 9902 which need the rtsp port setting in the configuration.yaml to be able to see the live stream. As Foscam is now an integration, the rtsp port cannot be set anymore and therefore all my cams are not visible anmore, also not in “auto” mode, which gave me a “freeze picture” before.

I’ve been playing around with the newly added ability of using input numbers for threshold values in numeric state triggers.

  # - platform: template  # OLD CONFIG
  #   value_template: "{{ states('sensor.cpu_temperature')|float >= states('input_number.rack_fan_on_temp')|int }}"
  - platform: numeric_state # NEW CONFIG
    entity_id: sensor.cpu_temperature
    above: input_number.rack_fan_on_temp

However it looks like I will be sticking with the template trigger as this monitors both the input number and sensor for changes. Where as the numeric state trigger only listens for the sensor crossing the threshold set by the input number.

e.g. for the config I pasted above, if I adjust the input number below the current sensor state the template trigger will occur immediately but the numeric state trigger will not occur until the sensor updates (and crosses above the value held by the input number).

It’s an edge case, and won’t be of much significance to most people, just something to be aware of.


FOSCAM Integration seems to have an issue. Old configuration is pulled and does not work anymore while new UI integration failed in different cases. Waiting for upgrade.

Went back to 2021.1.5 (complete restore!) in order to continue to use and see Foscam security cams.

Unfortunately same issue here

Good Morning,

I’m seeing this error after updating. Supervised installation with docker in 20.04 Ubuntu. The recorder fails to start after this error:

Error during connection setup: (psycopg2.errors.DuplicateTable) relation "ix_states_old_state_id" already exists [SQL: CREATE INDEX ix_states_old_state_id ON states (old_state_id)] (Background on this error at: http://sqlalche.me/e/13/f405) (retrying in 3 seconds)

I’m running a postgres backend and have not had any issues previously.

1 Like

No really, just remove the “, 0x” from the OpenZWave key and you are there :slightly_smiling_face:

Similar to my problem, perhaps, so let’s hope some bright persons can help.
To me, it looked like it’s just the zwave devices that have disappeared, but even after restoring the whole config it’s still the same. And I got the same message as you. I’m on Intel NUC, debian 10, supervised. It was very stable in 2021.1.5.