2021.5: Stability, performance, triggers, color modes!

I have the same issue with the Lovelace control cards for Tasmota lights being broken (both for lights configured with MQTT integration and those configured with the Tasmota integration).

The issue was logged in detail as a bug during development:

but then it looks like it was just closed and ignored without being fixed in the PR:

Further, the reason given for implementing the breaking change:

Tasmota lights no longer supports deprecated white_value, use rgbw_color instead.

does not seem to be mentioned anywhere in the Tasmota changelogs:

(and I have tested that setting a value for ‘white’ still works fine for Tasmota lights, whether from the Tasmota console or MQTT, including for the latest Tasmota release.)

So there certainly seems to be something odd going on here.

@emontnemery could you please take a look at this, including the bug report issue #50095 (linked above).


Yeah I’d assumed that after reading the documentation hence the “dumb question” comment in my post, but thanks for confirming - I didn’t want to make a massive set of changes based on my reading comprehension alone.

I should be able to workaround keeping the previous object id (e.g. sensor.wan in my example) which prevents me redoing some composite sensors, automation references etc. with some judicious titling and tooltipping in Lovelace.

Were there any breaking changes to zwavejs like zwave_js_value_notification events? I am not getting any events on minimote button press whereas i can see it in the log on zwavejs2mqtt.

denonavr users, i reported the issue :


Hello ! I’ve got the same error :frowning:
What do you mean by “rebuild zwavejs2mqtt” ? :slight_smile:
Thanks !


anyone can help me here

21-05-06 13:11:52 INFO (SyncWorker_0) [supervisor.docker.interface] Updating image homeassistant/raspberrypi4-64-homeassistant:landingpage to homeassistant/raspberrypi4-64-homeassistant:2021.5.0
21-05-06 13:11:52 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image homeassistant/raspberrypi4-64-homeassistant with tag 2021.5.0.
21-05-06 13:11:54 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install homeassistant/raspberrypi4-64-homeassistant:2021.5.0 -> 500 Server Error for http+docker://localhost/v1.40/images/homeassistant/raspberrypi4-64-homeassistant:2021.5.0/json: Internal Server Error ("readlink /mnt/data/docker/overlay2: invalid argument").
21-05-06 13:11:54 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant

I started from a fresh imagine, but it doens’t work

I get the same 2 error message every 10 seconds since update. I don’t have a clue where even to look, can someone give me an idea?

2021-05-06 15:21:30 ERROR (MainThread) [homeassistant] Error doing job: Future exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
TypeError: 'NoneType' object is not callable
2021-05-06 15:21:30 ERROR (MainThread) [homeassistant] Error doing job: Future exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
TypeError: 'NoneType' object is not callable
1 Like

I dont know how you installed zwavejsqmqtt, was it via npm or from git?

Hello guys, did anyone have tried to configure the new integration for the iAlarm alarm system?
I have the the XR main unit from Antifurto365.


My HA instance is on the same layer-2 network as the alarm unit and I can ping it from HA with no problem at all.


I get only this for a Move:

2021-05-06 15:48:39 ERROR (MainThread) [homeassistant] Error doing job: Task exception was never retrieved                                                                                                                     
Traceback (most recent call last):                                                                                                                                                                                                                                          
  File "/usr/src/homeassistant/homeassistant/components/sonos/speaker.py", line 261, in async_update_device_properties                                                                                                                                                      
    await self.async_update_battery_info(battery_dict)                                                                                                                                                                                                                      
  File "/usr/src/homeassistant/homeassistant/components/sonos/speaker.py", line 270, in async_update_battery_info                                                                                                                                                           
    if is_charging == self.charging:                                                                                                                                                                                                                                        
  File "/usr/src/homeassistant/homeassistant/components/sonos/speaker.py", line 289, in charging                                                                                                                                                                            
    return self.power_source != "BATTERY"                                                                                                                                                                                                                                   
  File "/usr/src/homeassistant/homeassistant/components/sonos/speaker.py", line 284, in power_source                                                                                                                                                                        
    return self.battery_info["PowerSource"]                                                                                                                                                                                                                                 
TypeError: 'NoneType' object is not subscriptable               

Anyone with the same problem or any advice?

Nice to see the announcement of color wheel support for RGBW devices. But I also see that I have to be patient to enjoy this for my Fibaro RGBW441 and RGBW442 devices.

They were working with OpenZWave Beta. I’m missing this with ZWave JS + ZWave2MQTT…

1 Like

device_tracker seems it didn’t work with fritzbox anymore, and adding it as integration add’s a lot of *_2 entities and im not willing to rewrite all automations, scripts and so on. how did i get rid of the *_2 problem, or how can it just ignore the new integration and for gods sake use the old one who worked fine?

same here. dozens of *_2 entities right now, and all are not_home even if they are.

Can you guys please move the deprecated vs legacy debate to another thread? Way too much back and forth on this subject in the blog post.


Delete your known_devices.yaml file and restart HA

when that happens, the _2 ones are the newly created ones, and you should try to delete the old ones. In/from known_devices.yaml.
If a restart after that doesn’t work that out for you, you can manually delete them from the core.entity_registry, but you can break your config if you make a mistake… so be very careful.

After that, repeat, if not already automatically done, you can rename all _2 ones and delete the suffix in the integration configuration panel

unless of course your _2 ones are created by another integration than the current ones, and then you should not delete the old ones, but rename the new _2 ones.

This is probably not your case as you moved from a manual yaml configuration to a new config UI integration?

I had the same error, after restart. I use it in a docker. (core v2021.5.0)

Logger: root
Source: /usr/src/homeassistant/homeassistant/bootstrap.py:312
First occurred: 17:04:28 (1 occurrences)
Last logged: 17:04:28
Uncaught exception
RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd

I fixed mine by rolling back the update temporarily via snapshot, then removing the device tracker entry in my configuration.yaml and after that reapplying the update and the new integration.

As mentioned elsewhere basically if you just go for the update with the config settings still in place you get each device twice, once each way. And by doing this the new integration ones should just drop in with the same device id’s as the old one (unless you’ve edited or changed them in known_devices.yaml or elsewhere). If so then the new device ID’s will need to be adjusted in a similar way.

My system is now back up and running correctly by doing that, plus a bit of a spring-clean of old unwanted devices in my Fritzbox that ended up with undesired devices in HA.

1 Like

Is it me or is the iCloud integration broken in this release? I get a “Config flow cannot be loaded” error when I try to add this integration again also see log below. First I removed it because it was giving errors during startup and did not load the entities.

Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2851, in get_entry_map
    ep_map = self._ep_map
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2813, in __getattr__
    raise AttributeError(attr)
AttributeError: _ep_map

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_protocol.py", line 422, in _handle_request
    resp = await self._request_handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_app.py", line 499, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_middlewares.py", line 119, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/security_filter.py", line 56, in security_filter_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/request_context.py", line 18, in request_context_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/ban.py", line 74, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/auth.py", line 135, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/view.py", line 131, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/config_entries.py", line 128, in post
    return await super().post(request)
  File "/usr/src/homeassistant/homeassistant/components/http/data_validator.py", line 63, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/data_entry_flow.py", line 72, in post
    result = await self._flow_mgr.async_init(
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 150, in async_init
    flow, result = await task
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 168, in _async_init
    flow = await self.async_create_flow(handler, context=context, data=data)
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 669, in async_create_flow
  File "/usr/src/homeassistant/homeassistant/loader.py", line 493, in get_platform
    cache[full_name] = self._import_platform(platform_name)
  File "/usr/src/homeassistant/homeassistant/loader.py", line 498, in _import_platform
    return importlib.import_module(f"{self.pkg_path}.{platform_name}")
  File "/usr/local/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 783, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/src/homeassistant/homeassistant/components/icloud/__init__.py", line 12, in <module>
    from .account import IcloudAccount
  File "/usr/src/homeassistant/homeassistant/components/icloud/account.py", line 9, in <module>
    from pyicloud import PyiCloudService
  File "/usr/local/lib/python3.8/site-packages/pyicloud/__init__.py", line 3, in <module>
    from pyicloud.base import PyiCloudService
  File "/usr/local/lib/python3.8/site-packages/pyicloud/base.py", line 20, in <module>
    from pyicloud.services import (
  File "/usr/local/lib/python3.8/site-packages/pyicloud/services/__init__.py", line 8, in <module>
    from pyicloud.services.account import AccountService
  File "/usr/local/lib/python3.8/site-packages/pyicloud/services/account.py", line 6, in <module>
    from pyicloud.utils import underscore_to_camelcase
  File "/usr/local/lib/python3.8/site-packages/pyicloud/utils.py", line 3, in <module>
    import keyring
  File "/usr/local/lib/python3.8/site-packages/keyring/__init__.py", line 6, in <module>
    from .core import (set_keyring, get_keyring, set_password, get_password,
  File "/usr/local/lib/python3.8/site-packages/keyring/core.py", line 149, in <module>
  File "/usr/local/lib/python3.8/site-packages/keyring/core.py", line 65, in init_backend
    keyrings = filter(limit, backend.get_all_keyring())
  File "/usr/local/lib/python3.8/site-packages/keyring/util/__init__.py", line 20, in wrapper
    func.always_returns = func(*args, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/keyring/backend.py", line 167, in get_all_keyring
  File "/usr/local/lib/python3.8/site-packages/keyring/backend.py", line 128, in _load_backends
  File "/usr/local/lib/python3.8/site-packages/keyring/backend.py", line 152, in _load_plugins
    for ep in entry_points:
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 641, in <genexpr>
    for entry in dist.get_entry_map(group).values()
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2853, in get_entry_map
    ep_map = self._ep_map = EntryPoint.parse_map(
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2534, in parse_map
    for group, lines in data:
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3190, in split_sections
    for line in yield_lines(s):
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2394, in yield_lines
    for ss in strs:
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2765, in _get_metadata
    for line in self.get_metadata_lines(name):
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 1417, in get_metadata_lines
    return yield_lines(self.get_metadata(name))
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 1409, in get_metadata
    return value.decode('utf-8')
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa1 in position 2: invalid start byte in entry_points.txt file at path: /usr/local/lib/python3.8/site-packages/pandas-1.2.4.dist-info/entry_points.txt

I’m having the same issue with IQVIA. Ever since the update it isn’t working. “Waiting on integrations to complete setup.”

1 Like