2021.5: Stability, performance, triggers, color modes!

Multiple adguard instances!!! Yes you guys rock!

No longer required. You still need to know them though to call the service.

I had the same issue and fixed it by adding this to my docker

      - /dev/serial/by-id/:/dev/serial/by-id

then restarting the docker.

Anybody having issues accessing in an iFrame? I typically have the “organizr” app with HA open via the iFrame method. After this last update I get the login prompt and the “stay logged in” popup, but only the blue top bar and white background are shown for the main window. I’ve tried deleting site information, using incognito, as well as a different browser. Same all around.

1 Like

agree with you this was a flawless update, and yes, enjoying many improvements (I have already been playing with during 8! betas…) but exactly what is the advantage of rewriting all your template (binary) sensors?

Works great except HACS. At config/integrations it keeps saying failed to setup. ( instellen mislukt, DUTCH)
Already tried if deleting HACS and reinstalling would solve the problem, but it didn’t. It’s just a message, HACS works!

Other problem is in the log file:
Logger: root
Source: /usr/src/homeassistant/homeassistant/bootstrap.py:312
First occurred: 22:50:53 (1 occurrences)
Last logged: 22:50:53
Uncaught exception

RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd

1 Like

Ouch! You make it sound like I scrapped what I had and recreated every part of it in a new way. The conversion simply involved changing the names of several options and adjusting indentation. Now all my template-based sensors and binary_sensors are consolidated in a templates.yaml file. I prefer that compared to what I had before: Template Binary Sensors in one file (binary_sensors.yaml), Template Sensors in another file (sensors.yaml), and Trigger-Based Template Sensors in yet another place (templates.yaml).

completely trashed my ZHA network - ZHA service keeps crashing and having to tear it all down and start again. 2021.5 isnt great for me!

Has the known_devices.yaml file finally been purged out or something in this update?

Just looking at my set-up post update, and my device tracking (and associated integrations) seems to be utterly wrecked. This is using a Fritz!Box, and I seem to have gained an AVM Fritz!Box Tools integration (alongside the existing Fritz!Tools one I have via HACS) and all my device trackings are now duplicated with the original ones not working (showing not_home) and the duplicates seeming to work (except some of the Android ones aren’t pulling the names correctly from the router).

Renaming known_devices.yaml away doesn’t seem to help anything, but it also doesn’t get recreated, hence the question…

Same issue here, think something is up with the integration.

When I inspect my Docker containers in Portainer I see that the addon is not in the hassio network (core-mariadb etc. are though) but also trying to access it via the Docker host IP ( when Ingress is enabled for motionEye does not work.

I suspect it has something to do with the input fields though. I keep getting “User input malformed” until I fill in all the fields (admin user/pw, surveillance user/pw), then it shows me “Failed to connect”. I’m not even using passwords, just the default user (hold your horses, I know) with no password

cant add any ZHA devices or discover them, now having to re-install from scratch and setup from scratch entirely.

A month ago or so, someone mentioned that 2021.5 will bring changes to actionable notifications which will not be needed to be pre-configured in .yaml file.
Is release of this improvement postponed or just missed from the blog entry?

It’s a change directly in the app. The according version is not out yet (only via TestFlight)

1 Like

Ah, nice
I can finally see the status of my cats again, after being broken the last month
The state of the flap door does not work, tho.
And is there manual on how to change the state of the flap door?


I was able to get it through the setup by designating a port in the configuration of the addon but then it locked me out, I assume because I didn’t actually forward the port on my router and was doing this all remotely.

Circadian Lighting (also a custom integration) stopped working too.
The two (adaptive lighting & circadian lighting) basically do the same, I believe.


Yes, glad someone else is having the same issues. On 2021.4.6, I was already starting to have some issues with ingress apps not loading, like VSCode, ESPHome and even Supervisor when in iframe. I thought I was going crazy or my proxy config was borked because it worked fine one day and was broken the next.

Just updated to 2021.5 and now iframe loading does not work at all. I tested some settings under the HTTP integration such as CORS and x-forwarded-for to see if that might be it, but no go.

1 Like

I do have the same HACS error in the integrations page.

My custom integrations and themes work.
My frontend cards don’t work anymore. The error in lovelace: “Custom element doesn’t exist:”

No messages in the log file??

1 Like

My frontend cards do work. No errors in lovelace.
No errors in the logfile. Everything works. Only at config/integrations an error that HACS cannot setup.

1 Like


Just did a restart of HA and a forced reload on the browser and my cards are back.
I think the forced reload of the browser did bring them back.

1 Like