2021.6: A little bit of everything

ha supervisor options --logging <level>

Where <level> is debug, info, warning, error, or critical


There was an OS upgrade released recently. Hass is now at version 6.

Now it looks like the restarts stopped and HASS now is running for 25 minutes without a restart.
But now all the icons for binary sensors are not showing any more (door or window open or closed). This worked fine for many years.

This 2021.6. is a very strange and problematic update. Too many broken functions, a lot of problems.

I need to correct. This is only the case in the Android app. Using the web interface the icons are still visible. It looks like the app is not yet ready for this version.

You just need to clear the app cache.

Not sure how to do this in Android. In iOS you go to App Configuration / Debugging / Reset Frontend Cache. It’s probably similar in Android.

Months ago developers were warned that unless they had a m,anifest with a version number, this release would block their work. many developers chose to ignore this advance warning. The breakage generally is because of this.

View the log files, not the logs from the ui. The supervisor logs you listed only show 1 ha startup too, not “restarting over and over again”

1 Like

And where I can find other log files? I have a samba share activated. Are some other log files available there? I really will need to solve this, because after restarting Hass it is again in an enless restarting loop. And from next night I will not be at home till Friday and it would be fine to get a working Hass before.

They are in the config directory named home-assistant.log

1 Like

This log I know, and I use it. But the issue is: This log will be truncated on every restart, it contains only 2 minutes between two restarts. But I will never see the last entries before truncation which could contain the error message. What I miss are some backups of this log: Instead of just truncating this log it would be fine to rename is, containing a timestamp, and if hass would keep some versions. Then I could find the last entry in these logs and maybe this would help.

For now the only way I see is to downgrade, using the ssh web terminal with

ha core update --version 2021.5.5

The translations are maintained by the community. The German one has already been updated, so with the next major release, you will see the correct translation.

The log file HA creates may clear every restart but the system journal does not. HA is set up for journal logging so if you go to the host shell you can get to the system journal and use journalctl see everything that’s going on from every container and across restarts.

Or alternatively check out the promtail and loki add-ons I made so you can see your logs from grafana. I haven’t looked at the log file in quite a while personally.

EDIT: you can also get to the journal file from the ssh addon under /var/log/journal. Since the ssh addon is alpine based not Debian you can’t use journalctl to view them from there. But you can move the files to another machine to browse them. Or back them up.


Regarding grafana I will need to learn what it is and how to use. I found a grafana addon in hass, which I installed, but I did not yet configure and started.

Regarding ssh: Currently, I installed the SSH Web Terminal add-on to get ssh access directly in the hass sidebar. I only used this to downgrade hass to an older version to get it stable working again. But when I list folders using SSH I get only the same folders, which I get via the samba share.

Should I additionally install the official ssh add-on, to get these log files under /var/log/journal? Is it possible / recommended to have both ssh add-ons installed in parallel?

Well unfortunately that doesn’t exist so you’ll have to make due. You can use a text log viewing software that updates when it sees changes in the logs. Like notepads++ or bare tail or vscode.

I am using these editors. But I never was able to catch the last moment before the file was truncated. Maybe I should create a feature request.
For now I am back on 2021.5.5. So next week when I am not at home Hass will work.

The ssh & web terminal addon is the one with journal access, the official one doesn’t have it.

Like you ssh’ed in and typed ls, is that what this means? If so you’re in the home directory which is /root. You have to change directory to /var/log/journal to see the journal files.

The samba addon also does not have access to these files so you won’t see them from that one.

1 Like

Exactly same here with SR-7010

roll back to 2021.6.3 or wait for 2021.6.5.

1 Like

Just noticed that I’m seeing this error message pop into the log when I’m scrolling a logbook card in lovelace when using the iOS apps on iPhone and iPad.

If I scroll up a bit (especially when scrolling fast) multiple lines print out showing this error. Not so much when going slower. I don’t see any other data it puts out besides what I have shown below. No issues seen when doing the same thing in web browser.

I noticed this in 2021.6.3 and it is the same in 2021.6.4.

Let me know if I can provide any other info to help fix it or if I should report it elsewhere. Thanks.

2021-06-14 11:10:42 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.
2021-06-14 11:10:42 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.
2021-06-14 11:10:44 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.
2021-06-14 11:10:44 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.
2021-06-14 11:10:47 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.
2021-06-14 11:10:47 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.
2021-06-14 11:10:53 ERROR (MainThread) [frontend.js.latest.202106030] :0:0 Script error.


Card YAML:

type: logbook
  - input_text.hvac_call_msg
  - climate.thermostat
  - group.someone_is_home
  - group.door_left_open
  - automation.thermostat_controller_4
hours_to_show: 24
title: Thermostat log

I’m seeing the same error, but not when scrolling the log, but when I scroll the list view of my automations, the scroll suddenly freezes and the only way to make HA respond to any mouse actions, is to refresh the browser. I run HA 21.6.4 in Docker on a NAS.

Logger: frontend.js.latest.202106030
Source: components/system_log/__init__.py:190
First occurred: 8:44:35 PM (6 occurrences)
Last logged: 8:46:42 PM Uncaught TypeError: Cannot read property 'attributes' of undefined