2022.12: It does matter!

Hello everybody,
anyone have my same problem? when I click on a “button” on the dashboard, it flashes the whole map



It’s ZHA integration issue, no plugins or add-ons were used.

I’ve already reported it, but it just gets ignored or closed.

That does not make sense if you also say you run native ZHA. What github issue was closed? If you report ZHA issue with a Sonoff bridge running Tasmota then it makes sense it gets closed.

1 Like

I was referring to this wording

anyone else with this problem?

Does anyone have an issue with their LG WebOS TV?

Logger: aiohttp.server
Source: components/webostv/__init__.py:133
First occurred: 5:36:26 PM (3 occurrences)
Last logged: 5:37:47 PM

Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 138, in read_http_response
    status_code, reason, headers = await read_response(self.reader)
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/http.py", line 120, in read_response
    status_line = await read_line(stream)
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/http.py", line 194, in read_line
    line = await stream.readline()
  File "/usr/local/lib/python3.10/asyncio/streams.py", line 525, in readline
    line = await self.readuntil(sep)
  File "/usr/local/lib/python3.10/asyncio/streams.py", line 617, in readuntil
    await self._wait_for_data('readuntil')
  File "/usr/local/lib/python3.10/asyncio/streams.py", line 502, in _wait_for_data
    await self._waiter
  File "/usr/local/lib/python3.10/asyncio/selector_events.py", line 854, in _read_ready__data_received
    data = self._sock.recv(self.max_size)
ConnectionResetError: [Errno 104] Connection reset by peer

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/local/lib/python3.10/site-packages/aiohttp/web_protocol.py", line 435, in _handle_request
    resp = await request_handler(request)
  File "/usr/local/lib/python3.10/site-packages/aiohttp/web_app.py", line 504, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.10/site-packages/aiohttp/web_middlewares.py", line 117, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/security_filter.py", line 60, in security_filter_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/forwarded.py", line 100, in forwarded_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/request_context.py", line 28, in request_context_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/ban.py", line 81, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/auth.py", line 236, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/view.py", line 136, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/config_entries.py", line 180, in post
    return await super().post(request, flow_id)
  File "/usr/src/homeassistant/homeassistant/components/http/data_validator.py", line 73, in wrapper
    result = await method(view, request, data, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/data_entry_flow.py", line 110, in post
    result = await self._flow_mgr.async_configure(flow_id, data)
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 281, in async_configure
    result = await self._async_handle_step(
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 368, in _async_handle_step
    result: FlowResult = await getattr(flow, method)(user_input)
  File "/usr/src/homeassistant/homeassistant/components/webostv/config_flow.py", line 98, in async_step_pairing
    client = await async_control_connect(self._host, None)
  File "/usr/src/homeassistant/homeassistant/components/webostv/__init__.py", line 133, in async_control_connect
    await client.connect()
  File "/usr/local/lib/python3.10/site-packages/aiowebostv/webos_client.py", line 73, in connect
    return await self.connect_result
  File "/usr/local/lib/python3.10/site-packages/aiowebostv/webos_client.py", line 105, in connect_handler
    main_ws = await asyncio.wait_for(
  File "/usr/local/lib/python3.10/asyncio/tasks.py", line 445, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.10/asyncio/tasks.py", line 650, in _wrap_awaitable
    return (yield from awaitable.__await__())
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 659, in __await_impl_timeout__
    return await asyncio.wait_for(self.__await_impl__(), self.open_timeout)
  File "/usr/local/lib/python3.10/asyncio/tasks.py", line 445, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 666, in __await_impl__
    await protocol.handshake(
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 326, in handshake
    status_code, response_headers = await self.read_http_response()
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 144, in read_http_response
    raise InvalidMessage("did not receive a valid HTTP response") from exc
websockets.exceptions.InvalidMessage: did not receive a valid HTTP response

Not that I have noticed, if I remember I’ll test tomorrow.


hi version 2022.12.9 is available for me since today (2023-01-03) , but it refuses to install, popup keeps spinning, and after 1 hour waiting, refreshing the page still shows it is available, opening the page will show ‘installing’
rebooted HA, did not help, after that it shows 2022.12.9 is available again, and 2nd time installing it gets same loop.

any ideas?

I have no idea, but the latest releases (12.8 and 12.9) seems to have resolved the issues for me.

If you are using an original ZBridge connected via WLAN, your problems are likely deeper than 2022.12.*:

Mine didn’t last longer than a week before needing a hardware reset and binding restart, and the ZHA docs suggest the ZBridge Pro likely has the same design issue - which could explain closed issues.

No problem here with my one, although I am running 2023.1 beta, so there may be a fix included, but I can’t see anything in the source that (on my quick) glance seems to be relevant.

No worries nick, thanks for checking anyhow. Do you by any chance know what the error message I pasted is pointing to? I can’t understand what the issue is even to start to find out.

Thank you for pointing this out my bad

It does matter … And now Matter disappeared?

Still being worked on, waiting for products to hit the market.

Did you manage to add any sensor? I tried but the integration doesn’t work

Yes i did, first try if you can “see” the sensor using the senserion app MyAmbience.
If thats the case u should have now problems adding it to homeassistant.
Config → Intergrations → add Senserion BLE
If you can not “see” the sensor there’s someting wrong with the sensor.

1 Like

Captură de ecran din 2023-02-16 la 16.44.46|231x500
Sorry for the delay
I have 4 sensors, 2 with old firmware and two with updated firmware that I don’t see in home assistant
I loaded a demo firmware (arduino ide - ) into a wemos lolin lite and it is detected by both the app and the home assistant

Best thing to do is file an issue at the github page.
By the way do you know this project?
It’s ment for diy but could also solve your problems because you can also connect throug mqtt.

I built sensors for a company that wanted to give employees more details about air quality in offices. The sensors send data to the mobile application, and in parallel it sends the measurements to a database. the collected data is processed and distributed in a web application for company management