2022.2: Let's start streamlining!

see this post: Legacy Nest - #7 by allenporter


I’m holding off, too.

I did not upgrade Tasmota on my devices, I changed the autodiscovery messages with a script. A lot less work.

The old one I had in case I had to recover them (only the first shown)

      - service: mqtt.publish
          retain: true
          topic: homeassistant/light/689626_LI_1/config
          payload: '{"name":"lichtbovenkleineslaapkamer","cmd_t":"~cmnd/POWER","stat_t":"~tele/STATE","val_tpl":"{{value_json.POWER}}","pl_off":"OFF","pl_on":"ON","avty_t":"~tele/LWT","pl_avail":"Online","pl_not_avail":"Offline","uniq_id":"689626_LI_1","device":{"identifiers":["689626"]},"~":"lichtbovenkleineslaapkamer/"}'

The new one:

      - service: mqtt.publish
          retain: true
          topic: homeassistant/light/689626_LI_1/config
          payload: '{"name":"lichtbovenkleineslaapkamer","cmd_t":"~cmnd/POWER","stat_t":"~tele/STATE",stat_val_tpl":"{% raw %}{{value_json.POWER}}{% endraw %}","pl_off":"OFF","pl_on":"ON","avty_t":"~tele/LWT","pl_avail":"Online","pl_not_avail":"Offline","uniq_id":"689626_LI_1","device":{"identifiers":["689626"]},"~":"lichtbovenkleineslaapkamer/"}'

Thanks, hadn’t seen that one. Hopefully someone takes over maintenance (I certainly don’t have the required skills). I might try to copy the code to my custom component folder and hope for the best…

Hi all,

Why is the old NEST deprecated???
Smoke sensors are not supported in the new intergration… It doesn’t make sense to stop the old intergration then?


See Legacy Nest - #7 by allenporter


I’ve found my two amcrest cameras have timed out a few times (but not every time) during a restart. When they timeout, the only option is to restart again and hope they connect.

So maybe add Check configuration and Restart Core to this new Check update menu?

Welcome to new streamlining experience, thanks to all developers who made it happen, worried and scared to update :slight_smile:

As a genuine question, why remove the default_config: directive at all? Seems like everything can be overridden even with it?

how to fix error for device_tracker:

2022-02-03 09:13:59 ERROR (MainThread) [homeassistant.setup] Error during setup of component device_tracker


Hey, does anyone know if this is caused by something from HACS or from HA? I don’t know how to fix it to update to the new version…

[Errno 2] No such file or directory:

*/usr/local/11b/python3.9/site-packages/multidict 6.0.2.dist-info/METADATA'

1 Like

Means I have to wait when this will be core in HACS and then update my HA…

Hi @rsachoc

It is not a light entity. It is a sensor entity. I saw the reference to state_value_template in the notes that you reference. I tried changing my config to use the state_value_template instead of value_template but when i ran the check configuration button it gave an error. So i don’t think this is it.

I am seeing the similar results as @nikito7 has posted. If i check states in developer tools. The state on the MQTT topic jumps from the correct value if the topic msg has my value_template var in its json. If it doesn’t, the entire json string of the topic msg is show in the state (see @nikito7 post for an example)

An example of the config i am using can be seen on the OMG documentarian OMG (Mijia Thermometer BLE)

1 Like

Is remote_rpi_gpio integration also going away in near future?

1 Like

I just upgraded.
Still no be able to browse my spotifty and cast it to my nest mini or my TV ?

Exactly. And door sensor icons are assumed “open” when unknown. Super annoying. Any ideas how to fix that other than getting rid of the RF433 door/window sensors?

1 Like

Any idea how to make RF433 door sensors (Binary switches) assume that when “unknown”, they’re closed? Addition of “unknown” state made all my custom Lovelace colors (green when closed, red when open) and automations useless after HA reboot until first state change, which is… suboptimal. Also the icons are “open” when the state is “unknown” (the doors are almost always closed in fact).

Some sort of “assume state: closed” option would be nice.

Any tips other than getting rid of RF433 and going zigbee?

How about changing them to red when open, green otherwise?

1 Like

That’s the big developer brain I don’t have :slight_smile: thanks. Doesn’t solve the “open” icon though (I have main entry door icon as a Badge).