2022.3.0 Radio Browser not initialized

Hi all,

I have the Radio Browser integration added and it appears under Media in the sidebar.

However I get “Radio Browser not initialized” when I click on the icon.

I found this in the logs

Logger: homeassistant.config_entries
Source: components/radio_browser/__init__.py:25
First occurred: March 3, 2022, 19:33:49 (1 occurrences)
Last logged: March 3, 2022, 19:33:49

Error setting up entry Radio Browser for radio_browser
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 335, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/radio_browser/__init__.py", line 25, in async_setup_entry
    await radios.stats()
  File "/usr/local/lib/python3.9/site-packages/radios/radio_browser.py", line 122, in stats
    response = await self._request("stats")
  File "/usr/local/lib/python3.9/site-packages/backoff/_async.py", line 133, in retry
    ret = await target(*args, **kwargs)
  File "/usr/local/lib/python3.9/site-packages/radios/radio_browser.py", line 73, in _request
    result = await resolver.query("_api._tcp.radio-browser.info", "SRV")
aiodns.error.DNSError: (1, 'DNS server returned answer with no data')

Yes, I read the instructions…what am I missing?

Many thanks.


FYI - I note this has been raised as an issue by another user:

Just wondering, are you able to lookup the address from inside your network?

nslookup -q=SRV _api._tcp.radio-browser.info


dig SRV _api._tcp.radio-browser.info

Thanks @7ee1441f5a

I ran nslookup and got no response.

As I run dnsmasq, I then implemented the solution you posted on github (commented out #filterwin2k in /etc/dnsmasq.conf) and now it works!

Much appreciated.

1 Like

I need a bit more context with this to understand how to solve this.
I do have the same problem that the Radio Browser integration won’t initialise at startup. I am using a clean HA OS install. Nslookup gave me no response.

Home Assistant Core 2022.5.3

Home Assistant Supervisor 2022.05.0

Home Assistant OS 7.6

Kernel version 5.10.108

Agent version 1.2.1

From the previous posts i understand that a setting in dnsmasq blocks the retrieval of SRV records. DNSmasq isn’t a part of the HA OS so the problem lies outside the scope of HA, right?

But how to solve this issue?
Investigation of my router (an old Sitemon gigabit 300n) didn’t show me an possibility to fix this. However i did find in the manual that dnsmasq is a part of the product but can’'t be reached.
So are there any other suggestions to solve this beside replacing the router?

Much appreciated.

1 Like

May help others as I managed to fix my issue…

Home Assistant uses my ISP for DNS resolution (Virgin Media in my case). For some reason, my ISP nameservers does not respond when querying that SRV Radio Browser record.

So I updated HA config to use Google’s DNS and then Radio Browser worked.

ha dns options --servers dns://

Where do you do this or in which file. I’m having the same problem. Thank you

NSloopup server