2022.4 broke the duckdns + nginx remote access (actually it was outdated certificate)


I had a working configuration to connect my HA from outside my home network.
After upgrading to 2022.4 i’m nop able to connect from internet anymore.
I have tried with iOS companion app and also from my work computer.
Both connections worked fine before the upgrade.
Now from iOS I get “An SSL error has occurred and a secure connection to the server cannot be made. NSURLErrorDomain -1200”


I don’t have an answer for you, but I can say that I have had that issue in the past (couple years ago), and it is a pain. But I am running a similiar config (NGNIX, with external DNS), and http internal, and I am not having any issues.

Everything is fine here (I think)

EDIT: checked, everything working.

Maybe your internal ip got blacklisted due to failed logons, can you access your log?

I have the same problem … since update to 2022.4 I cannot access HA via duckdns anymore.
It is totally accessible locally but via duckdns I get This site can’t be reached.
I haven’t changed anything and duckdns has proper IP assigned. Tried rebooting but problem is still there.

This is from my homeassistant.log

ERROR (MainThread) [aiohttp.server] Unhandled exception
Traceback (most recent call last):
File “/usr/local/lib/python3.9/asyncio/base_events.py”, line 1183, in _sendfile_fallback
read = await self.run_in_executor(None, file.readinto, view)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/local/lib/python3.9/site-packages/aiohttp/web_protocol.py”, line 514, in start
resp, reset = await task
File “/usr/local/lib/python3.9/site-packages/aiohttp/web_protocol.py”, line 460, in _handle_request
reset = await self.finish_response(request, resp, start_time)
File “/usr/local/lib/python3.9/site-packages/aiohttp/web_protocol.py”, line 613, in finish_response
await prepare_meth(request)
File “/usr/local/lib/python3.9/site-packages/aiohttp/web_fileresponse.py”, line 286, in prepare
return await self._sendfile(request, fobj, offset, count)
File “/usr/local/lib/python3.9/site-packages/aiohttp/web_fileresponse.py”, line 99, in _sendfile
await loop.sendfile(transport, fobj, offset, count)
File “/usr/local/lib/python3.9/asyncio/base_events.py”, line 1162, in sendfile
return await self._sendfile_fallback(transport, file,
File “/usr/local/lib/python3.9/asyncio/base_events.py”, line 1192, in _sendfile_fallback
await proto.restore()
File “/usr/local/lib/python3.9/asyncio/base_events.py”, line 263, in restore
File “/usr/local/lib/python3.9/asyncio/sslproto.py”, line 343, in resume_reading
AttributeError: ‘NoneType’ object has no attribute ‘resume_reading’

OK, turned out that the reason (for my system at least) was not 2022.4, but outdated certificate.
I was able to renew it, but the duckdns + nginx combination still not working correctly.
Now I get this: “502 Bad Gateway nginx”

when in doubt, restart both containers (addons). Nginx, then DDNS.

Power off and back on to raspberry did the trick. Now I’m able to connect from both lan and wan.


1 Like