2022.8.0 Setup failed for influxdb - Importing the numpy C-extensions failed

Hi all,
upgrading from 2022.7.x to 2022.8.0 i’ve got this error:

Logger: homeassistant.setup
Source: setup.py:192
First occurred: 19:20:49 (1 occurrences)
Last logged: 19:20:49

Setup failed for influxdb: Unable to import component: IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE! Importing the numpy C-extensions failed. This error can happen for many reasons, often due to issues with your setup or how NumPy was installed. We have compiled some common reasons and troubleshooting tips at: Troubleshooting ImportError — NumPy v1.24.dev0 Manual Please note and check the following: * The Python version is: Python3.9 from “/srv/homeassistant/bin/python3” * The NumPy version is: “1.23.1” and make sure that they are the versions you expect. Please carefully study the documentation linked above for further help. Original error was: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.29’ not found (required by /srv/homeassistant/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-arm-linux-gnueabihf.so)

I’ve home assistant core installed on RaspberryPi4 with Raspbian (Debian Buster).
I tried to uninstall/reinstall numpy but I still have the issue on influxdb integration.

Do you have any suggestion?
Thank you

I tried to downgrade from 2022.8.0 to 2022.7.5 (with which everything worked regularly) but the error remains.
Any suggestion or workarounds?

UPDATE:
Fixed upgrading Python from 3.9.9 to 3.10.6 and reinstalling HA in a new venv with the new Python version.