2022.8: You can fix it!

I just upgraded from 2022.7.x to 2022.8.2, and not seeing any issues with Philips HUE thus far.

2022.8.0 has been very unstable/buggy for me. HA was constantly unresponsive, falling off the network, automations not working etc. Emporia Vue custom integration was also broken.
I even tried to update to 8.2 multiple times, but it just would not happen.
Just rolled back to 2022.7.4 and everything is back to normal.

Hello, I am adding an Ip Camera via ONVIF integration. After adding the camera, I get an error, what could be the problem?

I am very positive, I have updated to 2022.8.2 two days ago. Last night, a new update of 2022.8.3 pop up. I even made a full backup naming it 2022.8.2 so I can update to 2022.8.3 the next day. It’s the next day and the new update is 2022.8.2.

Heck, I even saw the breaking changed dated for Aug 8 below yesterday. It’s not there any longer.

I have the same error, nothing so far works

Since Repairs is build in and warned me that Spotify should not be in YAML so I removed the lines. When I try to add the Spotify integration I get the warning: INVALID_CLIENT: Failed to get client

Steps I tried:

  • remove app from spotify dev and re-create it
  • remove home assistant from apps in your normal account.
  • looked for .spotify-token-cache and media_player.py but could not find them.
  • tried https:/ /my.home-assistant.io/redirect/oauth as well as https:/ / in the spotify dev app. (I broke the link with a space between the // to keep the link visible)

nothing seem to work and all result in the same error: INVALID_CLIENT: Failed to get client.

I have no clue where to look anymore. I run Home Assistant supervised through Docker on a Debian bullseye machine.

can anyone help?

found the solution:"Spotify configuration error (INVALID_CLIENT: Failed to get client) - #19 by Mijn.Handen

Other than this… keep up the great work, stuff is getting better and better.


The folder sensor does not work anymore in HA 2022.8 … Folder - Home Assistant

  1. The configuration files
- platform: folder
  folder: /config/media/camera

    media: /config/media
    - /config
    - /config/media/camera
    - /config/media/backup
  1. the error log
Logger: homeassistant.components.websocket_api.http.connection
Source: components/hassio/__init__.py:705
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 12:33:12 PM (6 occurrences)
Last logged: 2:24:29 PM

[140284496455872] The system cannot restart because the configuration is not valid: Not a directory @ data['allowlist_external_dirs'][1] Invalid config for [sensor.folder]: not a directory for dictionary value @ data['folder']. Got '/config/media/camera'. (See ?, line ?).
[140284513768576] The system cannot restart because the configuration is not valid: Not a directory @ data['allowlist_external_dirs'][1] Invalid config for [sensor.folder]: not a directory for dictionary value @ data['folder']. Got '/config/media/camera'. (See ?, line ?).
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 199, in handle_call_service
    await hass.services.async_call(
  File "/usr/src/homeassistant/homeassistant/core.py", line 1713, in async_call
  File "/usr/src/homeassistant/homeassistant/core.py", line 1750, in _execute_service
    await cast(Callable[[ServiceCall], Awaitable[None]], handler.job.target)(
  File "/usr/src/homeassistant/homeassistant/components/hassio/__init__.py", line 705, in async_handle_core_service
    raise HomeAssistantError(
homeassistant.exceptions.HomeAssistantError: The system cannot restart because the configuration is not valid: Not a directory @ data['allowlist_external_dirs'][1]
Invalid config for [sensor.folder]: not a directory for dictionary value @ data['folder']. Got '/config/media/camera'. (See ?, line ?). 

Is it a known issue ?
Thank you

EDIT : I responded to @beaulebens by mistake

Never mind, I tried the upgrade again, and everythings OK now… :thinking:

2022.8.3? Did I miss something?

I think 8.3 was merged with 8.2 or I was in a dream that lasted 24 hours.

2022.8.3 core isn’t out yet. That was likely a supervisor release

1 Like

Had the bluetooth_le integration working perfectly fine, since the update to this release, not getting a single scan happening.
OS is showing no issues and is able to scan quite happily.

Thoughts anyone?

I am also noticing the same thing. My Supervisor says there are no updates beyond 2022.7.0. Here is the output from CLI…

[core-ssh ~]$ ha supervisor update
Processing... Done.

Error: No supervisor update available - 2022.07.0

Have you figured anything out?

That is the latest stable version of supervisor. The current beta version is 2022.08.3.

Since update to 2022.8.x my climate entities (5 honeywell evohome thermostats) not sync to google assistant/home anymore and got remover from my Google Home dashboard after doing the HA update.

Can someone please help I reported the issue twice but seems there is no movement on it.

Logger: homeassistant.components.google_assistant.smart_home
Source: components/google_assistant/trait.py:896
Integration: Google Assistant (documentation, issues)
First occurred: 10:52:55 (20 occurrences)
Last logged: 11:03:49

Error serializing climate.home_family_verrips
Error serializing climate.living_room
Error serializing climate.bedroom_kids
Error serializing climate.bedroom
Error serializing climate.bathroom
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/components/google_assistant/smart_home.py”, line 85, in async_devices_sync_response
devices.append(entity.sync_serialize(agent_user_id, instance_uuid))
File “/usr/src/homeassistant/homeassistant/components/google_assistant/helpers.py”, line 623, in sync_serialize
File “/usr/src/homeassistant/homeassistant/components/google_assistant/trait.py”, line 910, in sync_attributes
modes = self.climate_google_modes
File “/usr/src/homeassistant/homeassistant/components/google_assistant/trait.py”, line 896, in climate_google_modes
for preset in attrs.get(climate.ATTR_PRESET_MODES, []):
TypeError: ‘NoneType’ object is not iterable

If I set my 5 climate entities to “not expose” in manage devices in google assistant settings within Home Assistant Cloud settings then the errors dissappear

So it looks like the problem is within Nabu Casa Cloud

Might have the same, still looking into it.

Using bluetoothctl, I can tell the devices are being “seen”, but they appear as “away” in HA. Also the BLE transmitter on my Android HA-App is on and defintely seen by bluetoothctl multiple times for multiple minutes. No entries showing up in known_devices.yaml though. I’m relatively sure this was the case in 2022.8.2, since my known_devices.yaml went from 550 lines to about 42000 in a day after setting track_new_devices: true.

But, ofc, I might be completely off here.

Thanks. I was assuming that they marked the Supervisor releases on Github as a Pre-Release like they do on Core.

Found this… https://github.com/home-assistant/version/blob/a75d334903d5d5fe8015de9b93e870ba8235d7ea/stable.json

Concerning the Folder platform issue , the camera folder is a nfs file so it could be the problem as another “normal” folder is working fine ( backup )

See initial post #333 above