2023.2: How can I Assist?

Wow, thanks, that’s great! I wasn’t aware that such documentation even existed. Really useful. Not really in plain sight, though.

Thanks for the new release :+1:
But how can I configure a 15-minute interval in the history graph card (like it is shown on the release screenshot)? There is only a hours_to_show parameter with a minimum value of 1 in the yaml.

You might need the to use it w/ 2 dashes in front and inside quotes: "--state-binary_sensor-off-color": red

Kind shocking reaction. Is this how we help each other in this community?

Yes I am apparently not an average user, because I managed to get things working by fiddling and surfing for hours and ours. Would be nice to hear if someone has ideas about upgrading MariaDB (in docker in my case)

I would add the version of the docker container in docker-compose.yaml like this:

    image: mariadb:10.3
    container_name: mariadb
    #-- rest of the stuff in docker-compose --

But Is that enough or do I need a data migration script to run or set some settings?


You need a Bluetooth adapter that can make active connections that is in close range to the toothbrush and it needs to be turned on.

The missing stats graphs are a problem with unit conversions and not the database.

1 Like

As I understand it you don’t need the breakout board or USB.
You can use something as small as this
Either 5 volt or 12 volt version

I ordered 10 of the LD2410 to see what they can do

Every statistical graph card with the % unit, i.e. percent, such as humidity, disk usage, cpu usage, etc, is broken by the update.

Might be rough for users that utilize the Synology NAS MariaDB package - current version is 10.3.32-140 and no indication yet from Synology of an update on the way.

1 Like

It’s not rough at all. All the issues that are now presented in the UI were issues in the past. So literally nothing will change if you keep the old version of Maria DB. You run exactly the same level of risk if you stay with 2023.1 vs 2023.2. The only difference is that HA now recommends you update (rather bluntly) to a newer version of maria db.

FYI: I run synology and I too am stuck on an older version of maria db, however I run 2023.2 without issues.



This isn’t a typical breaking change, you’ll notice the PR doesn’t even have the breaking change label. And it fixes this issue which was reported by a user running on HA 2022.12.1.

This is essentially a retroactive breaking change. As in HA has now been made aware of the fact that older versions of MariaDB have a serious issue that can break HA and HA cannot do anything about it (since you’re using an external DB service). Updating MariaDB fixes it. Not updating MariaDB means you risk hitting this serious issue whether or not you upgrade HA.

The recommendation to update MariaDB first is because HA knows its going to do a long-running query on upgrade to 2023.2 for a data migration to the new schema that could definitely trigger the issue. But even if you don’t upgrade, you may still run into it in normal HA usage.


After updating to v2023.2.0, addon SONOS AudioClip + Nabu Casa Cloud TTS GitHub - willscottuk/hassio-addons not working anymore and I don’t have option to open issue on github page, I get in the log:

Express server is running on http://ca51e721-sonos-audioclip-cloud-tts:8349
(node:75) [DEP0066] DeprecationWarning: OutgoingMessage.prototype._headers is deprecated
(Use `node --trace-deprecation ...` to show where the warning was created)
20:32:13 ✨ request completed GET 200 /api/speakText?playerId=RINCON_XXXEDITED&volume=15&text=The+window+is+open! 307ms

Ok, so would a man loose/gain anything by going to mariadb inside HA, found on official addons? I guess that it’s correct version…

@Petro got the syntax wrong. You have to prefix the css name by – (two dashes). Right Petro! Just like it is not documented

          - type: state-icon
            entity: binary_sensor.house_entry_motion_occupancy
            icon: mdi:account
              top: 3%
              left: 22%
              --state-binary_sensor-off-color: white
              --state-binary_sensor-on-color: red

Look a few posts up :wink:

So by all means, continue to complain about it instead of making a PR to update the docs to mention --. But that’s not your style, you’d rather complain about other volunteers not making that change for you.

1 Like

Same here. This happend also with other updates and in those cases unplugging/plugging the stick was the answer. Unfortunatly not with this update. My zigbee-network is down for a couple of hours now and I haven’t found a solution yet.

Am I correct in thinking that when the Assist voice-to-text facility is introduced, this will be local and not require sending audio over the internet?

I notice than when using Assist on an Android device, I do get a microphone button to dictate using voice, but this will use Google’s voice-to-text recognition won’t it, so does that mean the audio is being sent over the internet? I know that Google has offline voice typing, but I think that only works in Gboard (when a keyboard appears and you press its own microphone to speak) and if you’ve downloaded a language pack, so what does the microphone on the Assist text input box do?

I have same issue on my side using FullyKiosk. Since that 2023.2 update the screen stay white or with simple HA logo as you said. I tried to open it through Chromium and in such case it works, but through FullyKioisk, no way !
I rolled back to previous HA version and everything worked fine again on my FullyKiosk Tablet…

As of now we are using the Wear OS app is using the built-in speech recognizer. Depending on the device it may or may not use offline recognition. We don’t have control over that as we just use the API. I think the next steps is to do STT and TTS so we can then send over the audio file to HA and let it process etc…


If you are referring to the Web UI like from an android phone that is going to use the same thing from the browser like on other devices. The icon that you see is a standard icon shown when microphone is requested in a website.

After updating to 2023.2 my Mariadb starts upgrading as expected, but then fails in the end. Tried a few times but it keeps doing this. Any suggestions?