2023.6 Network Storage Feature - Experiences and Questions

Found the problem.

Left over crap causing me grief.

  media_dirs:
    media: "/config/www/media"

Sftp support in future?

1 Like

OK, I was able to successfully mount a share from my NAS as “backup.”

HA is still showing the local backups, and creating new ones on the local HA storage device. I restarted HA as well as rebooted the whole system (HAOS on a RPi.) No change.

Any ideas as to what I’m doing wrong?

Perhaps this needs to be selected. (under backups) I’ve not added a backup share yet.

1 Like

Doh!
That did it! Thanks!

1 Like

Sadly, it looks like there’s a fatal flaw in this new feature. @charredchar reported a disappointing test result here:

I am not exactly sure where it writes the backup files while it is creating the backup but I saw the free space shrinking during a backup and no new files on the share until it completed. Once completed the space freed up on the HA install again and the tar file appeared on the share.

So, it looks like we’re back to square one: Don’t use the HA backup if you don’t want to write excessively to your local storage device (like, if it’s low on space or it’s an SD card with limited lifetime writes.)

I was hoping to be able to automate the backups to my NAS right from HA, rather than have to “pull” just the config directory contents as part of my regular backup process, then manually do full HA backups sparingly, like just before I make a major change.

I haven’t tested the “share” option to see if that works the same way (writes locally, first.) If so, it wouldn’t seem much better than writing locally and just keeping it there.

I’m mounting to Synology SMB share.
Basic functionality works. With that I mean, that I can mount the network share and use it for backup.

However I cannot seem to make it connect to any subfolder of the share, which is a bummer.
I’ve got a “Data” share and if I enter just Data into the “Remote Share” field things work.
If I attempt to add any subfolders such as Data/Backups/HomeAssistant then I get a mounting error.

Am I missing how I should define the folder structrure or does this just not work for the moment?

Anyone having issues using the media, from the Network storage, inside the cards?

I am able to use /local/Images/xxxxxx.png for the items inside “Media-> My media”
Now inside said My media I also see the NAS folder I added and the images inside it. But if I try using it inside a card as /local/Images/NAS_Folder/xxxxxx.png doesn’t work

I understand it makes little sense to still use /local/xxxxxxxxx but I can’t find the proper way to do it

Would love to know the same.

I have a file platform set-up in my configuration so that I can create a text file using notify.text_file. Then I use a Mac automation to copy this file onto my laptop.

Long shot, but is it now possible to specify a path to create/add to the file directly onto a shared network storage folder? I managed to create a shared folder on my Synology NAS using the new network storage feature.

I tried setting ‘filename: /shared_folder/text_file.txt’ and variations on this, just getting error messages. I am at the limit of my knowledge and suspect that the new feature isn’t designed to do this. I would appreciate anyone confirming this (or giving me something to try!)

Yes. Define it in configuration.yaml using “/share” in the filename: parameter, like this:

notify:
  - platform: file
    name: testlogfile
    filename: /share/HALogFiles/testlogfile.txt
    timestamp: True
1 Like

I like it, but agree, it could use the file name instead of the hash. Also having a max number of backups would be nice…

But has anyone actually tried to restore a backup from the NAS storage folder?
I did, and it failed… It starts the restore, increases cpu load, but nothing happens…
After a few hours decided to restart, and it was still at the current…

Could be something wrong on my end (hence I figured I ask :face_with_raised_eyebrow: )
I ended up restoring a backup from an older SambaBackup, and copied the rest of the data manually from the ‘latest’. backup :thinking:

As soon as i have

Thanks so much for this. Yes it worked!

I thought I had tried that - but obviously had got something wrong.

Much appreciated.

I am using a USB stick attached to my router and mounted as samba share as a network device now for backups. The backups are created fine, but when I head over to “Config->System->Backup”, it says that I have no backups. It was the same with a samba share on a server…
When I look at the storage directly, I do have normally sized backup .tar files.
Anyone else experiencing these issues? Standard backup location is set correctly to the named share…

I saw that no backups issue when I was messing around with this too. Then it started working. Not sure if it was a restart, or a browser refresh, or just waiting, which got it working again.

No backups persists over reboot/restart/reload here.

Anyone know where the mounts are mounted?? I tried to check inside the /mnt directory but its empty.

I would like to offload some of my backups which have been built up onto my NAS without manually downloading then uploading.

Would also be nice when you hit “Create backup” you actually choose where you put that backup, and when you do have backups remote/local it should still show this back up in the list with a tag like “local/remote”.

At the moment taking backup to a remote location is a little pointless since you cannot restore from the GUI very easily, without manually uploading.

Hopefully this will come in the future.
But so nice to finally have remote shares land :partying_face:

this is great.
I can add my synology nas as target for the backups, and works perfect!!!

I will be interesting it we can change some local media folder to a diferent default target.
With this improvement we can use a folder for our nas to records of frigate, for example

I found if I have too many files in the backup folder then the HA UI just doesn’t show anything when going to backups. Backups complete just fine either way.

I would like to see a retention policy solution.

How many backups do you have?