2023.6 Network Storage Feature - Experiences and Questions

The ability to have HA OS mount network shares is a fantastic new feature of 2023.6. For some of us, it’s been long awaited.

So far all we have is the documentation here, and some posts in the release thread.

I’m starting this thread as a place to post experiences, good and bad, with this new functionality, as well as any questions left lingering after reading the documentation.

Tell us how you’ve used it, how it’s worked for you, what you’ve discovered, anything you’ve struggled with and anything you’re wondering about it. Let’s all learn hot to use this together!


Yeah will wait for a while and the go for the update :blush:

Works fine, but the backup configuration can be a bit confusing and it’s very barebones.

A SMB share starts with the sharename followed by the path with no leading slash. So it would look something like ShareName/Backups/HomeAssistant.

This is somewhat nonstandard and I’d prefer a URL like smb://NasHost/ShareName/Backups/HomeAssistant, but not a big deal.

Where the UI really falls apart is where you tell HASS to put backups in the new share. You need to go to backups and then click the three dots in the top right. That… isn’t very discoverable UI.

Then finally, it’s extremely barebones. The backup files themselves are seemingly randomly named (mine was bb70c72b.tar for example), they aren’t compressed (would like them gzipped), and there’s no way to configure retention, so it’ll save the files forever. Of course this is just the initial implementation, I’m sure this will all be addressed at some point.


I’ve defined a new network storage for backup using Samba to my NAS

How can I check if it’s working?

So from now on all the backup will be stored on network storage instead of local backup folder?

Will this work with addon like “Home Assistant Google Drive Backup” that have retention of local and GDrive backups?


Take a backup and check on your NAS that the file is there.

1 Like

Doesn’t work for me mounting my Buffalo Linkstation (Samba version 2):

Jun 08 14:49:13 homeassistant kernel: CIFS: Attempting to mount \\\media
Jun 08 14:49:13 homeassistant mount[2733910]: mount error(22): Invalid argument
Jun 08 14:49:13 homeassistant mount[2733910]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
Jun 08 14:49:13 homeassistant kernel: CIFS: VFS: cifs_mount failed w/return code = -22
Jun 08 14:49:13 homeassistant systemd[1]: mnt-data-supervisor-mounts-NAS.mount: Mount process exited, code=exited, status=32/n/a
Jun 08 14:49:13 homeassistant systemd[1]: mnt-data-supervisor-mounts-NAS.mount: Failed with result 'exit-code'.
Jun 08 14:49:13 homeassistant systemd[1]: Failed to mount Supervisor cifs mount: NAS.

Maybe it uses Samba version 3? :man_shrugging: my NAS has no NFS support.


I think you’re probably right. You could check the kernel log for a more descriptive error.

Good for a first effort, however specifying username and password for the share needs also to have ability to add a domain to the mix. I use Domain Active Directory in my network and the NAS uses it to authenticate the username/password.

So far, I have tried the backup feature to a mapped drive on my Windows server, and it is working great.
I am curious if I could use another shared mount to use in my YAML configurations, specifically, I want to be able to save DeepStack files to my server (see save_file_folder below).

  - platform: deepstack_object
    port: 5000
    api_key: mysecretkey
    save_file_folder: /config/www/deepstack/
    save_file_format: png

Here’s my first question: Does the backup really get created on the share that you’ve mounted as backup? Or is it created on the local storage then copied there, like all the backup add-ons do?

There is a Feature Request for the ability to give the backups (formerly called snapshots) a meaningful name. It’s sort of languished for a few years, but I think this new Network Storage feature might give it more justification. Please vote if you agree.

Also, isn’t .tar a compressed format? I guess I always just assumed that, so I could be wrong.

1 Like

Why is this limited to HA OS? I’d love this functionality, but use the Docker container.

Good question. This has been talked about a lot in the 2023.6 release thread and elsewhere.

As I (a plain ol’ HA OS user) understand it, the thought was that it’s not really needed in other OS configurations. If you’re already managing the OS and just running HA in a container or VM then you already have full control over what drives are mounted. I imagine you could run all of HA off a share from a remote server if you wanted.

What I suspect may be missing is the ability to run HA from a local drive, but create the backups on a (presumably already mounted) share. Or maybe you can and I’m just missing the details. So far the documentation has been fairly limited.

No, tar files are basically concatenated but not compressed. That’s why you often see them gzipped as well, as .tar.gz or .tgz.


yeah i guess samba3

Great feature, but the path structure is annoying.

I have a Windows Server, Path to backups in Windows would be

but in HA notation I have to use


Would be nice if this had at least been explained in the documentation :slight_smile:

So far Experience has not been good.

System: HA running in VMWare on a Windows 10 Host

  1. In the UI, creating the Network Storage ‘share’ seems successful as no errors are produced.
  2. The created share is NOT visible in ‘Media’ >> ‘My Media’ in the UI.
  3. Using Samba Share, I navigate to the Media folder and I see the share has indeed been created, and I can navigate the files.

Found the problem.

Left over crap causing me grief.

    media: "/config/www/media"

Sftp support in future?

OK, I was able to successfully mount a share from my NAS as “backup.”

HA is still showing the local backups, and creating new ones on the local HA storage device. I restarted HA as well as rebooted the whole system (HAOS on a RPi.) No change.

Any ideas as to what I’m doing wrong?

Perhaps this needs to be selected. (under backups) I’ve not added a backup share yet.

1 Like