2024.4 Tuya integration: lights white/color mode not updated

Hi,
Since HA 2024.4.0 I noticed that HA does not show the color mode correctly of my Tuya bulbs.

So

  • on/off is correctly displayed
  • when I change color in HA: icon shows the selected color
  • when I switch back to white modus in the Tuya app (I can’t switch to white modus in HA): the color of the icon in HA remains in color modus although the bulb works now in white modus
  • on/off works in HA, but when I want to change the brightness in HA, the old color modus is sent to the bulb

This makes that all my Tuya bulbs become more or less useless in HA:

  • I can’t switch to white modus in HA
  • I can’t dimm my lights because than they switch to a random color modus

Anybody same problem?
Any solution?

Kind regards,
Bart Plessers

2 Likes

I also have Tuya lights and also have this exact same issue. I hope this post gets more attention and a fix is rolled out.

I don’t know enough about Home Assistant to find a fix.

See also:

@KelsoUSMC : with “exact” do you also dealing with this problem since release 2024.4.0?
Did it work correctly before?

Worked perfectly before 2024.4.
So, yes… exact.

Hi @KelsoUSMC ,
this is relative “good” news.

Can you also check following:
after some investigation, I noticed that this problem only occurs with Tuya lights that only support [white + color]
I have some other Tuya bulbs that support [white with colortemp + color], here the above problem does not occur…

So I don’t know if you have some bulbs that also support (white + colortemp) and color.
For those lights, I see in the interface:

and there is no problem when I switch to white-modus or color-modus: both the Tuya app and HA display the status correctly.
It seems that the problem only occurs with bulbs that do NOT have the colortemp feature…

can you check this for me?

Is this a light that has the capability of white+colortemp???
I mean, can you -in the Tuya app- change the white from “cold white” to “warm white” but stay in white modus?

I installed a previous version of HA (2023.3.1) on my proxmox server. Here this problem does not occur.

On following screenshot:

  • left image: HA 2024.3.1
  • right image: HA 2024.4.2

What I did:

  • in HA changed color of the bulb to blue
  • in TUYA-app, I changed back to white

Version 2024.3.1: shows the correct state of the bulb
Version 2024.4.2: state of bulb is NOT updated and remains blue

I guess I’m not sure what you mean by cold white, warm white, or color temp…
I can set the color or set it to [CCT (Only in Tuya)]

In the last week, if I control my lights with HA, it automatically changes out of CCT and into color mode. If an automation runs that modifies the brightness, it goes to color mode.

The only way to get it back into CCT is the Tuya app or, “Alexa, set the lights to WHITE.”

Whatever type of lights I have, my issue is IDENTICAL to your original post.

01da2a820373cf4a8f79fb52557d7571d3731e9b_2_253x500

Just noticed this in Developer Tools

@bartplessers I have reached out to 2 of the authors that made changes to the Tuya light component. I’m waiting to hear back from either of them.

2 Likes

Hi @KelsoUSMC

In example, following screenshots from my Tuya app

TYPE 1

This bulb supports white with CCT and color:


You can see that you can select a warm white on the left side of the arc, and a cool white (more blue) on the right side of the arc. The light still remains in “white modus”, but you can modify the correlated color temperature (CCT)
What is CCT? A guide to choosing correlated color temperature for your lighting.
Beside this, you can also choose the “color modus” (on the top, select “kleur”).

In that case, you can choose any RGB color that you want

TYPE 2

This bulb only supports white and color

You can see that there is no color temperature selector in the arc. The white modus supports only one temperature of white.
Beside this, you can also choose the “color modus” (on the top, select “kleur”).

The problem we are dealing with does only occur on bulbs of type 2.
As far as I can see on your screenshot, is that in your “CCT” modus, there is no possibility to change the color temp. It seems that you can only activate one colortemp. So it looks like it’s also a “type 2” bulb.

Hey there @tuya @zlinoliver @frenck
I don’t know why this thread isn’t getting any attention but I’m sure there are more than 2 people that use these type of Tuya lights.
Also, the code changes for Tuya Component relating to color mode were not in the release notes for 2024.4.

I have the same exact problem no white control…

1 Like

Hi @glabbe0299
Please, post also at github. Hopefully the developers will pick this up there!

1 Like

Opened a new bug report in the Tuya repository:

1 Like

Hi, I have this same problem since upgrading to 2024.4 it has broken 5 lights in my home that are White + RGB. From what I’ve seen in HA the attributes were showing the specific lights as only supporting HS colour mode
They work fine from the tuya app if switched back to white but HA automation will set it to random colours when triggered. I’ve also noticed that HA a couple of times has caused those specific lights to “fail” / reset and go into join / heartbeat mode

Just started using HA now and I have 4 tuya color + white and until I saw this thread I though I was understanding HA enough to get the lighr to go simply white 80%.

HA would do that but with bulb I color mode and that is much dimmer than white mode. I was trying all matter of effect: white_mode white: true etc everything I could find to get this to work and not drive me crazy as if I cannot understand how to simply turn a light on I white.

Works well in tuya. So essentially I have to create a rule that trigger a google home SDK call from my wall switch to get my light to turn on white mode using the activation in home that trigger tuya. With added delay. Or bypass HA and get the switch to trigger an automatiob in tuya.

So.much for HA simplicity, customization and centralization I though. Well I guess it is bug and someone will get to it eventually or is there a way for new setup to roll back 1 version?

Zak

Ok, so this issue is now getting picked up with 2024.4 Tuya integration shows wrong color mode · Issue #116326 · home-assistant/core · GitHub