So I’m running a NAS (ugreen) with docker and home assistant is one of the main dockers, obviously. However, after the 2026.8 update the setup migrated the http nginx proxy settings to the new network settings. I checked them and all seemed good. Now however, I had an update of my docker platform due to a firmware upgrade and the trusted proxy has changed its IP. Usually this would be easily solved, just change the IP in the configuration.yaml. Now I can’t, even if I reproduce the settings, they are apparently ignored entirely.
Effectively I’m locked out of my system, the local IP with 8123 port doesn’t work either:
My fancy URL throws a ‘Unable to connect to home assistant’
The host IP (both http and https) with port give NS_ERROR_CONNECTION_REFUSED
The docker internal IP obviously give a connection timeout.
I really don’t wanna rebuild my NPM, as I don’t feel that’s part of the issue whatsoever.
Could anyone point me into the right direction?
PS: I would have liked to be able to use the configuration.yaml as a back-up, which would have solved my case.
Yea, definitely try @fleskefjes suggestion. If that doesn’t work, if you have SSH setup, there is a way to change those HTTP settings in the .storage folder. The exact file name wasn’t mentioned, but petro brought attention to it in another post within the last couple of weeks.
Thanks for the replies!
I have found the core.config file in .storage. The internal URL is somewhat set as specified, but it just throws an unable to connect, or: NS_ERROR_CONNECTION_REFUSED to be precise.
I then edited the file “http” in .storage and added the ‘missing’ IP of the nginx docker (it seems to cycle between .2 and .7 as a result of a NPM reboot, I know, I should set it to have an internal static IP, I just hadn’t). After saving the http file, I restarted the Homeassistant docker and everything worked perfectly!
Thanks guys, couldn’t have done it without you!
Jeroen