24hr format instead of AM/PM in Europe

Can’t find the option to change time format. Where is this configuration?

Talking about this panel, it should be 20:41 and 5:54 instead of PM-AM, at least in my country (and most of other countries too).


Doesn’t it change when you change the language on /config/core?

Nope, I’m having the same issue and I’ve read older posts on this as well.
All other timestamps like loggbook, dev-state etc are in 24H format, but the “timelines” (what are they actually called?) are in AM/PM format.

1 Like

Fix has been merged but most likely wont arrive until 0.65 is released.



So there is hope in a few weeks? I googled now and I saw 2-3 year old posts about this issue, and I’m really concern about that fix coming this fast :slight_smile:

I am using latest HA, but I am still see AM/PM, not 24hr format.

  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Budapest

Is there any way to set 24hr format?

The time is displayed in the format specified by your browser. Check that the language settings of your browser are correct. For example, in Chrome it’s the display language that you need to set correctly.

1 Like

I have my browser set to English (United Kingdom) and I still get the AM/PM instead of 24-hour clock.

Detection scripts for browser time formats appear to be broken as well: https://stackoverflow.com/questions/27647918/detect-with-javascript-if-users-machine-is-using-12-hour-clock-am-pm-or-24-cl

Regardless… it would be nice if the language was auto-detected by default but would allow for overrides. Especially with software such as Home Assistant it would be nice to use the English texts intead of the localized versions since it helps searching for error messages.

WoLpH is right. In Mac OS X Safari time format is set in system preferences and already I have checked 24hour format, but HA still showing AM/PM.

1 Like

Same here. Extremely frustrating.


Any news on this subject? I also find this vey frustrating and am curious as to why so little people seem to have issues with this? At least judging by the number of comments and topcis we seem to be in the minority.


Yes, please if I set config to be metric then surely it should be 24h format.


Same problem here, everything set to 24h format and european time zone. Still get AM/PM.


Same issue here. All settings correct. It’s just HA that’s getting it wrong.


Confirmed. A nuisance - or dare I say : disrespect for the european users - that has been around forever …


As I said above, it’s the display language of your browser that controls this.

I want to force it to always show 24h format, regardless of display language. Can I do that?

1 Like


Would be great if this feature request outside of US would be taken serious. But maybe i should just be happy to not see Fahrenheit instead of Celcius :slight_smile:
I personally like to see ENGLISH text and still metric units.


This is not correct. I have the language set to one that does not use AM/PM, still get AM/PM in the logbook. All history graphs do however display the time in 24 h format.

1 Like