"401: Unauthorized" iframe CARD of Grafana not working on the www (local network ok)

Sounds like it may be a CORS issue, it may be worth checking the Grafana settings.

We’ve all checked the settings to the best of our knowledge (no doubt). I know I have…
thanks for the input. Will google it and see if I can find owt new with it :+1:

Same problem here. Unable to find a solution, but will keep you posted if I do…

2 Likes

Follow up the issue on github page. https://github.com/hassio-addons/addon-grafana/issues/55 Everyone has the same problem, no solution yet. The most logical comment comes from @jcwillox there. Could be an ingress session creation problem…

2 Likes

Never done a github issue, sounds fun!

1 Like

Just to report. I am having the same issue,
in lovelace I see 401, unauthorized
INfluxDB is working fine.
Grafana is working, it sees the data from homeassistant. First attempt of creating iframe is fine, nice graphs. after closing everything and trying it a while later, HA shows the 401 message.

Hope it will be solved with next update :slight_smile:

5 Likes

I’m also experiencing this, thought I had forgotten the damn password again :stuck_out_tongue:

2 Likes

I solved on my docker installation as github ticket suggest.
On docker server i installed sqlite3 package and then do the job

[email protected]:/# apt install sqlite3
Reading package lists... Done
Building dependency tree
Reading state information... Done
[...] [....]
[email protected]:/# sqlite3 /usr/share/hassio/addons/data/a0d7b954_grafana/grafana.db
SQLite version 3.27.2 2019-02-25 16:06:06
Enter ".help" for usage hints.
sqlite> select name from org;
TWProject
sqlite>

1 Like

Great that you solved it.
Do you suggest to ssl into hassio, login as root.
Type: ‘apt install sqlite3’
Then: ‘sqlite3 /usr/share/hassio/addons/data/a0d7b954_grafana/grafana.db’

I run Hass. IO as VM. Does this still apply?
I can test tonight,

[edit]
tried it just now. doesnt work on hassio i gues (or I dont understand it).

in my case i have hassio under a proxmox vm as docker
I did the sqlite3 procedure on vm not on hassio

@frenck
Just a quick question.
Do you recognize the issue we describe? or are we forgetting something obvious?

And just a big thanks to everything you are doing for this amazing project…
regards,

No you’re not forgetting about anything. It isn’t possible to do at this time to do. It simply won’t work due the way Ingress handles authentication.

2 Likes

Ah, ok. Thank you for the reply. :slight_smile:
I myself didnt get that clear answer through my skull yet. I was looking/waiting for a fix… ghehe.
Thanks for clarifying.
Cheers

@frenck
I saw on github the issue is closed, also a hint on that the ingress issue should be fixed now. Am I correct? If so, could you give a hints on how to set it up.

Iframe, influx+grafana should be such that I dont see the 401 message anymore?

What I tried is this in the grafana addon setup.
“grafana_ingress_user”: “admin”
should it be like this? anything else?
kindly tips :slight_smile:

regards

You can’t include iframes from Grafana from Ingress, this is not an add-on limitation and can therefore not be fixed via an add-on update.

The version re-instates direct access to grafana, which can provide access without ingress.

so to be clear no chance to resolve it for the hassio users here?

Hi Frenck,
can it maybe be done if i allow anonymous login? I don’t have any problems with that since grafana and home assistant is only accesable from within my LAN.
If so, how can i change the settings in grafana? I’m trying all day to change the settings (in the grafana.ini), via env variables and stuff, but can’t seem to find a way that works.
Greetings,
Joost

Okay, I’m able to make the iframe working like this. AFAIK, you can’t get ingress to work, so it won’t pass through nabu casa when you don’t have direct access. To remedy this, you’d have to punch a whole in your firewall for the port you define and use your external ip and port in the URL. Probably you only need anyonymous and embedding, but I just copy pasted that from elsewhere.

I just showed up to this issue and wanted to chime in. On my internal network, on mac safari 14, sometimes works and other times not, on the iOS HA app it always give an error - I get 401: Unauthorized on Grafana iframe card, but on Google Chrome, it always works on the mac but never on the iPhone. could there be some other way to integrate Grafana into lovelace besides the iframe card?

1 Like

Yes just to chime in this is the 1M$ question… What is the right way of displaying Grafana dashboards in Lovelace? Any support appreciated. And if it is not possible at all then I don’t really get the point of having a Grafana addon…

2 Likes