404 not found error - notification with frigate clip


I just upgraded from home assistant blue to a NUC with hassio. Upgrade was smooth without issues. Just transfered the backup. However, there is one problem that arised and that I have no idea where to begin to solve:

I have Frigate installed on my HA system and HA sends a notification to my android phone with a clip from the camera when a car drives into my front yard. This worked great when I had the system on the HA blue. After upgrading I still get the notifications but when I click on the view clip on my phone I get a 404 not found. I use a blueprint named frigate notification 0.11.03 - sgtb

Any ideas what causes this?

Potentially a different nabu casa ID, check that that part of the blueprint is set correctly

Thanks for your reply. I’ve checked the NC ID and it’s the same. Besides I find no place in the blueprint where I set the NC ID. I believe it uses websocket or something, but I’m not sure.

You have to set the external access to the nabu casa url otherwise it won’t work outside the network.

It just sends you to the url using the frigate integration http REST API, no websocket involved in opening a clip

Yes, I have done that. I can access HA from outside my LAN through NC. That works fine.

I get the same error when I’m on the same network as my HA server.

Do the recordings work and play when viewing in frigate directly?

Yes they do.

Any updates regarding this? Encountering the exact same issue. Notifications are being received, thumbnail and all, but trying to click it and view a clip or screenshot leads to a 404.

Unfortunately not. Still stuck. Don’t know how to fix it.

Have the exact same issue… get the notifications but can’t open it… 404.

Did anyone figure this one out? Having the same issue.

I managed to fix the problem I had. The problem for me was in the companion app. I use an android phone and cleared the app data and buffer. Had to set up the app again. Maybe it’s enough to only clear either the buffer or data.

1 Like