500 Internal Server Error

I tried doing an update today. AIO installed

• sudo apt-get update
• sudo apt-get upgrade -y
• sudo su -s /bin/bash homeassistant
• source /srv/homeassistant/homeassistant_venv/bin/activate
• pip3 install --upgrade homeassistant

The home assistant get about 60-80%, then displays massive amounts of red text. Which I can’t seem to copy, Now I get the following message:

500 Internal Server Error
Server got itself in trouble

Please help. I was so excited I got things up and running this far with added components and views. Now this… Bummed

There is an issue with the yarl dependency. You can fix this by downgrading: pip3 install --upgrade yarl==0.13.0 or wait for the 0.57.3 which includes a hotfix for this.

Typed: pip3 install --upgrade yarl=0.13.0

Invalid requirement: ‘yarl=0.13.0’
= is not a valid operator. Did you mean == ?

DANG! I will be back. My Grandaughter is here. I don’t ever want her to think the computer is more important than her.

Ah yeah, you need == :slight_smile:

Did I mess up the pip3 install line? I copied it directly from here.
? Thank you for the quick assistance.

I just tried: sudo pip3 install --upgrade yarl==0.13.0
was missing the second “=”

That worked. Thank you!!!

Another question. What is the latest version? Is it safe for me to try updating again or should I hold tight for a fix from the community?

Looking at other posts… Seems like I was not the only one experiencing issues with the update.

Found this: https://www.youtube.com/watch?v=tuG2rs1Cl2Y
Explains how to see what version you’re on.
Didn’t know there was a release almost every 2 weeks.

Thanks BEN!!!