500 Server Error on Installation of Home Assistant OS

Hello,

After several failed attempts to update the supervisor, I gave up and decided to just do a fresh install, especially since I had several devices die recently so things on my overview page were messy anyway.

Yet when attempting to do a fresh install, I get the same error as when attempting to update.

 22-03-03 11:37:51 INFO (SyncWorker_0) [supervisor.docker.interface] Updating image ghcr.io/home-assistant/raspberrypi4-64-homeassistant:landingpage to ghcr.io/home-assistant/raspberrypi4-64-homeassistant:2022.3.0
22-03-03 11:37:51 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image ghcr.io/home-assistant/raspberrypi4-64-homeassistant with tag 2022.3.0.
22-03-03 11:43:25 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install ghcr.io/home-assistant/raspberrypi4-64-homeassistant:2022.3.0: 500 Server Error for http+docker://localhost/v1.41/images/create?tag=2022.3.0&fromImage=ghcr.io%2Fhome-assistant%2Fraspberrypi4-64-homeassistant: Internal Server Error ("Get "https://ghcr.io/v2/": context deadline exceeded")

I definitely don’t use linux regularly so I could be missing something obvious, I’ve done my best to google around.

I’ve followed the guide in a thread about 500 errors for changing my DNS on the pi, but it did not resolve the issue. I’ve checked my router to see if anything was being blocked and nothing was as far as I could tell. I even changed my router’s DNS to 1.1.1.1. Still the same error.

Any ideas?

Things I’ve tried since this post: different router, different switch. different, brand new SSD card.

Same here tried everything I can only get home assistant to run on docker but its limited when compared to the OS version or the Supervised version.

Same issue here