502: Bad Gateway Node red Problems

Hello there i am new here and just installed Home assistant yesterday on my Raspberri 3b+. Now i wanted to install Node red but i get a Bad gateway 502 error. I looked true the forums but there is nothing to find that can help me…

I tried these things, Open in Webui would not work. credential secret a password to it.

I tried to ping the adres but get a request timed out. Sent 4 Recieved 0.

Windows Firewall off

I am out of options and i hope someone can help me. i will post the log here. If you want more logs please tell me where i can find them. I am complete a noob and starting and try to learn.

19-10-09 06:02:27 ERROR (MainThread) [hassio.api.ingress] Ingress error: Cannot connect to host 172.30.32.1:63219 ssl:None [Connection refused]

1 Like

Please elaborate.

When you try to INSTALL it, it fails with bad gateway? Or you installed it and trying to OPEN it, you get bad gateway? These are different processes, and need to be treated appropriately.

1 Like

It is installed on home assistant. When i want to open it, then i get a bad gateway error

1 Like

So you’ve verified your configuration settings in the add-on configuration? Nothing weird there, like telling it to use https when you don’t have a certificate, etc?

What happens when you attempt to open a tab up to http://ip:1880 ?

1 Like

if i copy and paste youre link in a new tab, nothing happens, wont open

1 Like

You can’t just paste that link directly…you need YOUR IP address in there

I tried it and it says the server takes to long to respond

1 Like

here is another log…:

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] nginx.sh: executing…
[22:30:35] FATAL:
[22:30:35] FATAL: SSL has been enabled using the ‘ssl’ option,
[22:30:35] FATAL: this requires a SSL certificate file which is
[22:30:35] FATAL: configured using the ‘certfile’ option in the
[22:30:35] FATAL: add-on configuration.
[22:30:35] FATAL:
[22:30:35] FATAL: Unfortunately, the file specified in the
[22:30:35] FATAL: ‘certfile’ option does not exists.
[22:30:35] FATAL:
[22:30:35] FATAL: Please ensure the certificate file exists and
[22:30:35] FATAL: is placed in the Hass.io ‘/ssl/’ directory.
[22:30:35] FATAL:
[22:30:35] FATAL: In case you don’t have SSL yet, consider getting
[22:30:35] FATAL: a SSL certificate or setting the ‘ssl’ option
[22:30:35] FATAL: to ‘false’ in case you are not planning on using
[22:30:35] FATAL: SSL with this add-on.
[22:30:35] FATAL:
[22:30:35] FATAL: Check the add-on manual for more information.
[22:30:35] FATAL:
[cont-init.d] nginx.sh: exited 1.
[cont-finish.d] executing container finish scripts…
[cont-finish.d] 99-message.sh: executing…

            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

1 Like

Did you actually read the error message?

I mean, I specifically asked if this was the case…

The error literally states that you have SSL configured but don’t have a certificate…so either disable the SSL option on the add-on configuration, or add valid certificates.

yes wrote message and i changed the ssl to flase this is my new config plus log from the add on…

This is my config
{
“credential_secret”: “”,
“dark_mode”: false,
“http_node”: {
“username”: “”,
“password”: “”
},
“http_static”: {
“username”: “”,
“password”: “”
},
“ssl”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: false,
“system_packages”: [],
“npm_packages”: [],
“init_commands”: []
}

LOG NODE RED

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.

[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 00-banner.sh: executing…

Hass.io Add-on: Node-RED

Flow-based programming for the Internet of Things

Add-on version: 4.2.1

You are running the latest version of this add-on.
System: HassOS 2.12 (armv7 / raspberrypi3)
Home Assistant version: 0.99.3
Supervisor version: 189

Please, share the above information when looking for help

or support in, e.g., GitHub, forums or the Discord chat.

[cont-init.d] 00-banner.sh: exited 0.

[cont-init.d] 01-log-level.sh: executing…
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] nginx.sh: executing…
[11:15:21] FATAL:
[11:15:21] FATAL: SSL has been enabled using the ‘ssl’ option,
[11:15:21] FATAL: this requires a SSL certificate file which is
[11:15:21] FATAL: configured using the ‘certfile’ option in the
[11:15:21] FATAL: add-on configuration.
[11:15:21] FATAL:
[11:15:21] FATAL: Unfortunately, the file specified in the
[11:15:21] FATAL: ‘certfile’ option does not exists.
[11:15:21] FATAL:
[11:15:21] FATAL: Please ensure the certificate file exists and
[11:15:21] FATAL: is placed in the Hass.io ‘/ssl/’ directory.
[11:15:21] FATAL:
[11:15:21] FATAL: In case you don’t have SSL yet, consider getting
[11:15:21] FATAL: a SSL certificate or setting the ‘ssl’ option
[11:15:21] FATAL: to ‘false’ in case you are not planning on using
[11:15:21] FATAL: SSL with this add-on.
[11:15:21] FATAL:
[11:15:21] FATAL: Check the add-on manual for more information.
[11:15:21] FATAL:
[cont-init.d] nginx.sh: exited 1.
[cont-finish.d] executing container finish scripts…
[cont-finish.d] 99-message.sh: executing…

            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

1 Like

First of all: When you copy error messages into the forums, use the CODE button so it’s formatted correctly.

Secondly, you are still telling your config that you have a certfile, exactly like the error message (again) is telling you.

Oke let me have a look how to do that… Config Changed to this ssl both False.
{
“credential_secret”: “”,
“dark_mode”: false,
“http_node”: {
“username”: “”,
“password”: “”
},
“http_static”: {
“username”: “”,
“password”: “”
},
“ssl”: false,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: false,
“system_packages”: [],
“npm_packages”: [],
“init_commands”: []
}

{[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 00-banner.sh: executing…

This is all the log i have from the add on

1 Like

Please learn how to use the code option in the forums.

Based on what you have provided, it would appear the add-on is running now…

I will learn it, But how come i still get the 502 error ? if i open it… ?

1 Like

Clear cache on your browser? Open in incognito mode?

Yes both already done, still nothing :frowning:

1 Like

Not the original poster. But changing the SSL to false is what fixed it for me. I have done zero configuration on my Home Assistant, I literally installed it, then added Node red, and needed to set a password, and change the SSL to false and the 502 Bad Gateway error went away. Thanks!

2 Likes

I had the same issue with several different addons including node red.

Issue: Firewall blocking
Solution: Allow inbound traffic

I had this same issue (I have require_ssl: false), even restarted HA, but got the same message that SSL was enabled. But then realized there is also another line with ssl: in the config file, and once I also set that to false, all worked fine.

I have the same problem with my install off Note Red in HA (502: Bad Gateway)
And I’ve also set
require_ssl: false
restartet and also rebootet HA, still the same:(502: Bad Gateway)