503 error when installing Hacs

any thoughts on this ?
Thanks

➜ ~ wget -O - https://install.hacs.xyz | bash -
–2021-09-05 16:17:10-- https://install.hacs.xyz/
Resolving install.hacs.xyz (install.hacs.xyz)… 172.67.194.112, 104.21.33.253, 2606:4700:3034::ac43:c270, …
Connecting to install.hacs.xyz (install.hacs.xyz)|172.67.194.112|:443… connected.
HTTP request sent, awaiting response… 503 Service Temporarily Unavailable
2021-09-05 16:17:10 ERROR 503: Service Temporarily Unavailable.

1 Like

I’m getting the same 503 error

If you didn’t get this, try the alternate link that uses a github url. It’s in the green tip bar at the bottom of the download instruction page.

wget -O - https://raw.githubusercontent.com/hacs/install/main/install | bash -

Thanks that worked!

Hello, Im new tiwh HA trying to install HACS on my VM, keep getting 503, Service Temporarily Unavailable. I had also tried wget -O - https://raw.githubusercontent.com/hacs/get/main/get, no working either.
Any help would be greatly appreciated.
Thanks

2 Likes

The link does a redirect that wget doesn’t like. Use the link that it redirects to. Currently:

https://raw.githubusercontent.com/hacs/get/main/get

image
this is what i get when i tried to install hacs. Anyone please help. TIA.

Try
wget -O - https://raw.githubusercontent.com/hacs/get/main/get | bash -

2 Likes

The problem is caused by Cloudflare:
DNS name get.hacs.xyz resolves to IP address 172.67.194.112, which belongs to Cloudflare:

$ whois 172.67.194.112
[Querying whois.arin.net]
[whois.arin.net]
NetRange:       172.64.0.0 - 172.71.255.255
CIDR:           172.64.0.0/13
NetName:        CLOUDFLARENET
[...]

When the link is accessed from a web browser (even lynx), Cloudflare recognizes it as a valid request, and redirects the request to https://raw.githubusercontent.com/hacs/get/main/get
However, requests from wget or curl are seen as suspicious, and denied. While wget gets a 503 response, curl displays content of a page requesting confirmation that you’re not a bot.

HACS has to change configuration of their service (if possible) to add wget to allowed user agents, but meanwhile you can use the direct URL on githubusercontent.com, or you can tell wget to introduce itself as another browser:

wget -O - -U "Lynx/2.8.8pre.4 libwww-FM/2.14 SSL-MM/1.4.1 GNUTLS/2.12.23" https://get.hacs.xyz | bash -