A newly added Third Reallity Button controls one of my aqara plugs without any settings

Some minutes ago I brought a thirdreallity smart button into my zigbee network.
RIght after adding it, without any changes made, a single press on this button turn on one of my aqara plugs, a double press turns it off.
This aqara plug is the nearest zigbee device to my button.
Because I obviously dont want this, I did reset the button and paired again - same result.
So I did reset it again and paired it next to my zigbee dongle (skyconnect).
Now it works perfectly fine.
What is wrong here? Why I get this?

Somehow button was bind to the plug. This is actually feature of zigbee, which make possible to create such scenarios like switch/light working without coordinator. Very useful in some cases. This feature is easy to control and create in zigbee2mqtt. I have no idea about ZHA, because I don’t use it.

Is this new, never before paired on your network?

It sounds like there is already an automation here. You didn’t say if your integration is ZHA or Z2M. I am using ZHA. Go to “Integrations”, click on the integration (Zigbee Home Integration, in my case), then on “devices”, then on the Aqara plug. In the section titled “Automations”, you will see any automations that use the switch.


Ah sorry. Im using ZHA here.
The thirdreallity Button (both ive tested) never have been on my network and should have been new.
(Atleast I purchased them as brand new devices).
There a two automations for the plug in question.
One is for my PV automation and one for getting its status via telegram bot.
Nothing else.
And as I mentioned.
When I pair the thirdreallity button next to the plug (where it should operate in the future), the strange binding occurs.
If I pair the smart button next to my skyconnect stick (and move it to the place next to the plug) everything works as expected.
So the “binding” only occurs when I pair my button next to the plug.

Ive got a few of these third reallity buttons. If there is time, ill pair another one next to another zigbee plug and see what happens.

But anyway, I want to pair it next to this plug to use it as a router, what seems to be not possible?

So is it perhaps seeing the plug as the nearest router to pair through, then using some in built algorithm to determine that the router is a switch and automagically biniding with it?

I wonder what would happen if you paired it through a zigbee bulb that is permanently powered?

I realized that the button automatically repairs with a night light (thirdreallity, too).
So its not connected directly to the skyconnect stick, as it was yesterday, anymore.
But even if its not connected via the aqara plug it turns it on and off again.
The automation Ive written for the button (locking and unlocking the - not zigbee - door) works perfectly fine. But again my plug is turned on and off.

I cant test the button with a bulb, because I only have WLAN shelly bulbs.

btw, nothing happens to the night light, if I press the button.
I unplugged this night light and the button connected to antother Zigbee plug (not the one its turning). This plug its now connected is a hue plug.
But still my button turns on and off the aqara plug, nothing happens to the hue plug its connected.

I checked the “group” tab in zigbee settings, but there is only a blank page.