A noob struggling with homeassistant

Hey guys, I’m completely new to HASS. I have a few smart devices and decided that HASS would be the best way to control them from one place. I have a spare android device and tried installing homeassistant with termux. It’s been a headache for the last three days. I almost succeeded by following a YouTube tutorial, but I could only connect to the GUI with the ‘server’ phone. HASS said that the 8123 port was busy and I was constantly getting 404 error. So I tried to reinstall with pip3 freeze | xargs pip3 uninstall -y and then pip3 install homeassistant
pip3 install aiohttp
pip3 install websockets
It didn’t work out at all. I’m getting all bunch of errors like “setup failed” and “could not build all dependencies”.

Could someone please help me.

Thank you for reading.


That looks like you were either using an old tutorial or chose an advanced user Home Assistant Core installation. That is not a good choice for a noob.

Please review your installation options.

I’m trying to install it on an android phone with Termux. Couldn’t find an official guide for that.

Home Assistant itself cannot run on Android. Termux is not supported either but the Linux options should get you close.

There is an app for Android that can be used to access a Home Assistant instance if someone does not wish to use the browser to do so.