A turn on problem with Magic hue/Flux_led


I’m having an issue that I’ve had for quite some time now.
I can turn off and see the state of my bulb quite easily. but if I try to turn it on again the following happens.

First the bulb doesn’t turn on. and the state is off still as the bulb didn’t turn on in Home Assistant.
In my magic home App I have to go to the bulb go in to the bulb turn off/ on there = no response from the bulb.
then go out and turn it on on when looking at the list of bulbs, then the bulb quickly turns on and then off again after a second. When I then go in to the bulb and turn it on then it will turn on correctly and work correctly in the app but once I use Home Assistant to either turn it on or off it won’t work again.
Off always works in home assistant but on never works, however Off will trigger the same behaviour in the Magic Home app where it takes a little fiddling with on off in the various list and device controls.

My question is there any way to fix this behaviour that Home Assistant is triggering ?
is there any way to get home assistant working with the bulb again ? as it was working a few months ago.

1 Like

Hi there, did you ever fix the problem? Because i’m experiencing the same “weirdness”… :slight_smile:

I am sorry my home assistant server burned down shortly after and have been struggling to get spare parts to fix it since.

Only resently have I been able to get a new version of home assistant up and running again so it will take me a few days or weeks before I am able to see if I still have this issue in the new version of home assistant

Sorry to hear that, mine was setup today, so i’m a total newbie… :wink:

If you still have the problem, i managed to fix mine…
The solution was to setup every bulb manually, and then to change the mode from rgbw (which is default) to rgb, like in the example below.
If your bulbs aren’t all the same, you should probably play around with the setting, until you find the right one. I found some info on this page: https://www.home-assistant.io/integrations/flux_led/
which helped me alot… :wink:


Example configuration.yaml entry

  • platform: flux_led
    name: flux_sofa
    mode: “rgb”
    name: flux_gang
    mode: “rgbw”
    name: flux_loft
    mode: “rgb”
    name: flux_spisebord
    mode: "rgb"´
1 Like

I’m happy that you found a solution to your problem I will try this out when I get time to mess around with it again. Christmas coming up means less time to setup stuff like this unfortunately.

If you’re having the bulb quickly turns on and then off again issue with the Magic Home controller I’ve posted a fix for it here:


Sad to report I have the same issue still. Will try your fix one of these days.

Thanks I will look in to this one of these days.

well I finally had time to try and figure this out. Your solution resulted in me loosing warm white which as unacceptable for me.

and your solution resulted in the same issue just in one of the other bulbs which is just a trade off imo.
So I decided to go back to the known issue rather than having some other bulbs behave strangely.

but thanks to both of you for trying. I have a hypothesis that I might be able to control the lights through automation even if the interface of Home assistant is not able to maybe my appdaemon addon is able to.

Yeah, that happened to me to, but didn’t investigate further, it is a non solution without warm white, since this is the clearest light.

I’ve recently implemented new router and stuff, since i needed HaProxy to access HA from outside via SSL, therefore non of my bulbs are currently set up, so it will be a while (probably), before i get back to it.

One of my bulbs though, actually worked with rgbw, as you could see in my example, this was also a different manufacturer (bought in a local hardware store in denmark), the other where “noname” bulbs bought from wish…

If i find a solution i’ll be sure to write it here, hope you will do the same! :slight_smile:

I’ve bought 3 from different places on wish. all 3 behave differently with Home assistant.

I have found my hack for now. I’m using a virtual switch in my smartthings hooked up to Home Assistant and ifttt in this manner I can turn on and off the light, I’m just sad I had to give up on local control.

Now my idea is to simply buy a new bulb from IKEA or Philips or similar, and use my smartthings as a simple Zigbee usb. I’ve given up on this bulb it is too much of a hassle imo.
Nice to see that I’m not alone in Denmark to use Home Assistant :wink:

by the way the AppDaemon solution was a dead end also. :frowning: