AArlo: camera.aarlo_total_cameras library websocket failed

Home Assistant 2023.3.0
Supervisor 2023.01.1
Operating System 9.5

I’ve been struggling to get my Arlo cameras to show up. I see in the logs the 2FA code is being picked up from my email it appears login to Arlo’s site is working but I still don’t see cameras showing up under Entities except for sensor.aarlo_total_cameras.

I do see these in my log file:

WARNING (SyncWorker_0) [pyaarlo] No devices returned from /hmsweb/v2/users/devices?t=1677789381346
DEBUG (SyncWorker_0) [pyaarlo] devices=[]
DEBUG (SyncWorker_0) [pyaarlo] : set:ARLO/totalCameras=0
WARNING (MainThread) [custom_components.aarlo.camera] camera.aarlo_total_cameras library websocket failed


I have been playing with this more and I am seeing my Arlo cameras by S/N showing up in the logs with the following.

2023-03-03 10:22:45.131 DEBUG (ArloBackgroundWorker) [pyaarlo] request-end=200
2023-03-03 10:22:45.131 DEBUG (ArloBackgroundWorker) [pyaarlo] skipping 4XH5767DB2A2F:2023-02-27T18:21:00
2023-03-03 10:22:45.131 DEBUG (ArloBackgroundWorker) [pyaarlo] skipping 4XH5767DB2A2F:2023-02-27T18:19:56
2023-03-03 10:22:45.131 DEBUG (ArloBackgroundWorker) [pyaarlo] skipping 4XH57679B22DD:2023-02-27T17:30:01
2023-03-03 10:22:45.131 DEBUG (ArloBackgroundWorker) [pyaarlo] skipping 4XH5767DB2A2F:2023-02-27T16:22:45
2023-03-03 10:22:45.132 DEBUG (ArloBackgroundWorker) [pyaarlo] ml:load-count=1
2023-03-03 10:22:45.132 DEBUG (ArloBackgroundWorker) [pyaarlo] initial refresh done

So it appears HA can log into my Arlo account successfully but after that they are not being added to Entities. Other than, sensor.aarlo_total_cameras.

Any help would be appreciated as I have been playing with this off and on for weeks.

If anyone has any suggestions I am all ears.

Here is some additional info. Looking through the logs again I found URL’s for presignedContentURL and presignedThumbnailURL which both work. This further confirms I am authenticating with Arlo and able to pull info from the cloud. What is still not working is the Card in HA and I am not seeing the entities in HA.

I’m hoping someone on here can help me out.

this is what I have setup in my dashboard to display my arlo pro 2 cameras. I created one for each camera

type: custom:aarlo-glance
entity: camera.aarlo_garage
name: Back of House
  - motion
  - battery_level
  - signal_strength
  - captured_today
top_title: true
top_status: false
top_date: false
image_bottom: onoff,motion,library,stream,signal,snapshot,battery

Thanks. What I am running into is the only entity showing up in HA for Arlo is
sensor.aarlo_total_cameras. The logs appear to show I am connecting to my Arlo account and seeing the cameras by S/N but they are not being added as entities. I’m not sure why not.

Did you manage to solve this problem? I have the same issue. No devices detected. I have not slved this yet.

No, I am still having the same issue.

For those who stumble upon this thread…

Turns out Arlo made a backend change that required me to update my Arlo account to a new UI experience. Until I went through the process to update the UI, cameras would not show up for shared accounts. Here is the link to how that upgrade took place. https://community.arlo.com/t5/Arlo-Secure/Invited-friend-cannot-see-devices-on-their-dashboard-Arlo-Pro-2/m-p/1889396#M1813. Once I did that everything worked!!

I used that same URL that @tcrake posted when I was debugging a different issue; trying to add my son as an authorized user was failing in the Arlo app. Once I went through the upgrade process I am no longer able to get hass to load my cameras. Any chance you could post the aarlo section of your configuration.yaml?