Ability to disable integrations

In my opinion it would be useful to be able to (temporary) disable integrations. For example: turn off telegram notifications during the night. According to my information the current solution would be add it to the condition part of an automation.

You don’t need to disable the whole integration.

Just create a “do not disturb” input boolean and use that in conditions.

You can even schedule the state of this using any one of the now available scheduler options.

1 Like

yes I know… but in my opinion is is more elegant to manage such things on a higher level.

1 Like

Well you know what they say about opinions.

1 Like

I would like this feature. When an integration does not work anymore but a fix is ongoing, we could disable the integration temporarily (no spam in log!!).

2 Likes

This would be extremely handy.

There are times when an integration temporarily breaks, and there’s currently no way to disable UI-based integrations, so instead it floods your logs etc. And often you don’t want to remove the integration completely because then you’ll lose all your customizations.

There should be a “Disable” option right above the “Delete” menu option when you click overflow (3 dots) menu on an integration.

2 Likes

Agreed.
I recently changed routers and had a hard time finding the IP of my lighting controller. Lots of errors instead of me just disabling my lighting integration until I sorted it out.
I don’t want to add an automation, input_boolean, etc. when I could just temporarily disable it.

Agree! My NAS is not always turned on, but HA throws a lot of errors when it cannot find the NAS. It would be nice to disable the integration instead of deleting it.

Same here. I have a kodi integration, but the device is only on if the tv is on. Thus most of the day the integration is spamming connection issue logs :’)

Hello,

I have WLED integration with a couple of WLED devices. One of them is also outside tree with christmas lights - as they will not be used for some time now I switched off the controller and power supply.

Now I have two lines of garbage in the HA log every 80 seconds:

ERROR (MainThread) [homeassistant.components.wled] Error fetching wled data: Invalid response from API: Error occurred while communicating with WLED device at 192.168.xxx.xxx
WARNING (MainThread) [homeassistant.config_entries] Config entry 'wled-SHC001' for wled integration not ready yet. Retrying in 80 seconds

So I definitely vote to add a disable option on Integration and also on Device level.

the same with Shelly Integration. D
It’s included to zeroconf so it recognize all shelly devices available in the network, cluttering integration page by offering all those devices to add to. Since I decided to use mqtt it’s useless and annoying.

Managing it from zeroconf is way suboptimal for obvious reasons.

Disabling integration would really help.

Plus 1!
this was exact the reason why I found this topic. I have the DMS integration configured for my backup NAS that’s nog always online.
Would be nice if you could disable the integration with a automation.

+1
You can turn off the integration if you turned off the device to prevent error spam.
For example,
When you turn off your synology or any device integrated in HA, HA spams lotsa errors because it cannot reach the device. Disabling the integration temporarily fixes this issue. You can even automate it based on a ping sensor or something of your choice.

+1. Need to have for Kodi that is spanning the log when my TV is off.

This feature has been added to HA.

You could also filter logs using the filter option: