Abode Integration Failing - Unable to connect to Abode: validation failed

I am getting the above message in my log, starting today. After doing some digging in the initialization code and attempting to duplicate it with curl, I am seeing the following difference…
curl -d ‘{“id”:"", “password”:""}’ -H “Content-Type: application/json” -X POST https://my.goabode.com/api/auth2/login
{“code”:400,“message”:“validation failed”,“errors”:[{“field”:“uuid”,“message”:“The uuid field is required.”}]}

After adding this:
curl -d ‘{“id”:"", “password”:"", “uuid”:“7”}’ -H “Content-Type: application/json” -X POST https://my.goabode.com/api/auth2/login

It now returns something…not sure if it’s the right thing. Was this an API change, or what am I doing wrong?

1 Like

I am having the same problem.

I am also having this exact problem.

Same here. +1

+1 on the same issue.

With the following change, it works again:

--- __init__.py.orig	2018-04-04 14:59:02.398420280 -0500
+++ __init__.py	2018-04-04 14:55:08.789472384 -0500 .
 @@ -95,7 +95,8 @@

         login_data = {
             'id': self._username,
-            'password': self._password 
+            'password': self._password,
+            'uuid': 7

         response = self._session.post(CONST.LOGIN_URL, data=login_data)

This is NOT the right fix (UUID is not supposed to always be 7, I don’t think :-)), but it demonstrates that this is the conceptual problem. If you want to test this…delete your pyc files for this module first, or copy it and import the new one.

Has anyone added an issue to the issue tracker?

I have no idea how to do what @BenMenchaca described. Can anybody guide this newbie?

Thanks Ben for the quick response.

To be clear - my response was not intended as a fix for the average user. I was attempting to point some knowledgeable dev in the right direction so they would not have to retrace my steps. Sorry if I implied otherwise :-).

Posted as an issue here: https://github.com/home-assistant/home-assistant/issues/13687

Yup same here

I’m getting the same error on 0.61.1.

Same problem her after upgrading to 0.66.1. I tried downgrading back to 0.65.6 and still saw the same issues, so as @BenMenchaca pointed out, this seems to be due to a change on abode’s end. Sure hope this is fixed soon. :frowning:

There is an issue opened in github for this and they are aware of the issue. My understanding is that it is on Abode’s end.

If the issues on Abodes end who knows if it will get fixed. I haven’t found them to be very attentive to their loyal customers of late

@nbraun18 I do not want to panic yet but home assistant compatibility is one of the main reasons I chose Abode. Many of my automations are tied in with Abode sensors :frowning:

Same here… I have my setup where abode handles security (sensors and locks) and HA handles the automation (lights and notifications). With the abode connection down, I lose a lot of HA functionality. :frowning:

Looks like @MisterWil wrote a fix and pushed it out (yay)! Any clue when this will make it to Hass.io? Since that is what I’m running, I don’t think I can update to the latest abodepy 0.12.3

Yep, this specific issue was due to Abode adding support for 2FA. Login now requires some form of UUID to identify a device and if they’ve used 2FA to login from that device before. The fix I submitted earlier just generates a random UUID on every login.

DO NOT enable 2FA right now if you want to keep using Abode with HASS. I’ll be working 2FA support into abodepy and the HASS component soon. :slight_smile:

I assume the pull request upgrading abodepy to 0.12.3 will be included in 0.67.


Thanks so much @MisterWil!!