Access to Console


I just installe HAss as VMware appliance. Web-GUI is working pretty nice. Now I was trying to install a CalDAV calendar based on the documentation.

To integrate a WebDAV calendar in Home Assistant, add the following section to your configuration.yaml file:

Well, that’s pretty nice, but:
How do I get to the console to add the statements to the configuration file? I do not have the root-password for the appliance nor is ssh access possible. The user I created at the beginning through the GUI is not allowed to logon to the console.
I was able to logon directly to the console screen an looks like I am in a restricted shell as “ha” (without password!) and the only command I can run is the “ha” command. Still no clue how to edit the mentioned file.

Is there no way to activate CalDAV through GUI?


Use the file editor addon.

Yes, works fine for configuration.yaml.

Unfortunately I own a couple of 1-wire devices. Most of them are perfectly discovered. But I have one which offers temperature AND humidity. According to the 1-wire-addon doc I have to do some database commands. Well, I assume this is not possible with the file editor addon…

Any further ideas?


At least you can give the built-in console in file editor a try (click the cog in the top right corner).

Ah, found it. But no. This is not going to work. I can type a command and it will print me the result but I can not do iteractive sessions (I tried to change the root password, did not work :()