Access token for node-red

Hi, I am trying to get an access token for HA from node-red.

It should be easy with this tutorial

Is it because I am using HA Core? A problem linked to npm? I am running the latest version 1.1.3.of npm and HA Core 0.115.0b7

Everything is running fine except I cannot get access to Home Assistant from node-red. The access token is refused.

Double check that the addon checkbox is empty for a venv/Core install.


That’s a point. Thanks! But I did check…
I also tried with coming back to the Core version 0.114.4 instead of 0.115.0b7

1 Like

The other thing to try would be to create a brand new token and try it. I use Core myself (both a venv version and a Docker version) and the only time I’ve run into issues was because HA decided it didn’t “like” my existing token.

Some other questions:
Is this a new install of HA and NodeRed?
What version of the ha-websockets are you using? The latest is 0.25.1.

1 Like

Thanks a lot, that was it: trying another token!
I tried 2 yesterday but I was unlucky. How come it works now?
Just because you were there? :thinking: :face_with_raised_eyebrow:

1 Like

Ha! I have no idea. I know that my HA has had issues with checking tokens from time to time but trying to reproduce it for a bug report has been REALLY difficult.

1 Like