Accessing hassio after months of inactivity

So life happened, and I ended up leaving hassio running on my pi3 for the last several months without touching it or thinking about it. I don’t remember when it stopped working (a couple months ago, maybe?), but now that I’m trying to get back into it I’m not able to access the web page or access it through SSH. I’m not entirely sure what the last version I ran was, but I’m pretty sure it was somewhere between 0.89 - 0.93. Any suggestions for where to start to get into it so I can start updating?

Can you ping it ?

Yes, and it’s showing up on my router page, so it’s connected to the internet.

Did you install ssh and samba ?

Yes, I used to have both up and running. Neither are connecting anymore.

If ssh is not responding, that sounds very bad.
You may have to try a hard reboot

Sorry, you didn’t actually answer francis

Yes, I can ping it. Could my SSH and Samba add-ins have switched off for some reason?

Not unless you turned them off or the pi has crashed (v. unlikely)
What response times are you getting on the ping ?
Is it wired or via wifi ?

1 ms ping time, and it’s wired

How much config did you have ?
Is it backed up ?
How big is your sd card ?
Did you have history turned off ?

A good amount of config, several third party integrations, etc.
I’m not sure how up-to-date my last backup is, but it should have most everything.
SD card is 32gb
History was on

You can attach a keyboard and use the magic sysrq key

1 Like

Stupid question but you did save the backup off the sd card didn’t you ?

If so (and even if it isn;t) hard reboot.
If it comes back you will have been lucky
else, do a new install and restore the back up

Yep, have my backups saved to dropbox. I’ll try rebooting.

try francis’s tip first

Awesome, I’ll look into this. Which command should I try - just rebooting?

I tried Alt + Sysrq + B to soft reboot, but nothing happened.

Try Alt + Sysrq + o to shutdown clean

Still nothing