Accessing HomeAssistant Front End Remotely

A little background about my setup:

  • I currently running CentOS 7.3.1611 with Docker installed
  • I’ve successfully installed and ran HomeAssistant within Docker
  • Port 8123 is opened on my server and have verified it on portchecker sites
  • I used DDNS that came with my router and have been successfully accessing applications on my server remotely via web browser

Docker Images

$ docker ps 
CONTAINER ID        IMAGE                                    COMMAND                  CREATED             STATUS              PORTS               NAMES
fec6f11b3e12        homeassistant/amd64-hassio-audio:14      "/init"                  48 minutes ago      Up 48 minutes                           hassio_audio
75541d43f1c3        homeassistant/amd64-hassio-cli:25        "/init /bin/bash -c …"   48 minutes ago      Up 48 minutes                           hassio_cli
b54c4996a732        homeassistant/amd64-hassio-dns:9         "/init coredns -conf…"   48 minutes ago      Up 48 minutes                           hassio_dns
63f8e85f0a16        homeassistant/amd64-hassio-multicast:2   "/init"                  48 minutes ago      Up 48 minutes                           hassio_multicast
52b24db9faa6        homeassistant/amd64-hassio-supervisor    "/init"                  49 minutes ago      Up 49 minutes                           hassio_supervisor

I’m having trouble accessing the front end for example,

Error showing from Firefox is

Unable to connect
Firefox can’t establish a connection to the server at

Firewall rule is opened as confirmed by portchecker.

$ sudo iptables-save | grep 8123
-A IN_public_allow -p tcp -m tcp --dport 8123 -m conntrack --ctstate NEW -j ACCEPT

The script I used to install homeassistant is listed in the [installation page](curl -sL “” | bash -s) of homeassistant. Once ran it started homeassistant in docker so there isn’t a need for me to run the following command. I don’t know if it has something to do with the “-net=host” option.

docker run --init -d --name="home-assistant" -e "TZ=America/New_York" -v /PATH_TO_YOUR_CONFIG:/config --net=host homeassistant/home-assistant:stable

Any idea?

“hassio” starts the container up with --net=host mode already on. That’s not your problem.

I figured it out. The below command didn’t show me any result until I rebooted.

$ ss -tulpn | grep "8123"
tcp    LISTEN     0      128       *:8123                  *:*