Accessing internet from HA problems, 'AddonManager.install' blocked from execution, no host internet connection

I have a problem sort of. I need clarity. I’ve scoured the forums both here and through google and cannot find anything that solves my problems. So I am reaching out for help.

I am setting up HA for the first time. I am running it on a Windows 10 machine through Oracle VM Virtualbox. All of the HA Software is updated. I am running core 2023.12.3, OS 11.2, and supervisor 2023.12.0.

It all started when I realized I could not cannot install any addons. I was able to install several earlier today. For instance, I installed both Mosquitto Borker and zigbee2mqtt with no problem. But, all of the sudden, I couldn’t install anything. I thought it was just with the Z-wave JS addon, but it turns out it seems to be with all addons. The problem is, whenever I try to install an addon, I get this message: ‘AddonManager.install’ blocked from execution, no host internet connection.

TL:DR; I had a static IP address set in the HA network settings and have had that from nearly the beginning of my setup. I also have a static IP assigned at the router level in addition to the IP identified in the IPv4 network settings. I have been able to install addons since setting this up. This did not change when I started having problems. After a ton of reading forums and troubleshooting, I realized nothing from HA was getting through to the outside internet (it wasn’t just problems with addons). So I decided to look at my DHCP table in my router configuration and I noticed that my HA installation was not showing up on my DHCP list like it had been earlier today. So I went to HA network settings and turned IPv4 back to automatic.

My question and need for clarity is:
If i have a static IP assigned to my HA installation at the router level, is it crucial that I have the the HA network IPv4 settings set to static?

Here are many of the steps I took to get to that point, if you are interested:
I’ve looked and looked for an answer to this, and while several folks seemed to have had this issue, very few have found a solution. Most posts on it seem to end up abandoned. Some seem to have found success reinstalling HA, but others have not. Following some recommended solutions, I have ensured my DNS was appropriate. I changed it to and, and made sure it was at the router level. To no avail.

I tried setting the date manually. No dice. I tried this command: curl ‘’ and got the response “curl: (6) Could not resolve host:

I have rebooted HA and the computer it is hosted on multiple times.

I did find one post in the community here in Aug 2022 that stated that disabling the host_internet check helped (using command ha jobs options --ignore-conditions internet_host). So I tried that command through terminal. That actually prevented the host error when attempting to install the JS addon, but it just sat there, attempting to load then returned this error:

Failed to install add-on

Can’t install homeassistant/amd64-addon-zwave_js:0.4.3: 500 Server Error for http+docker://localhost/v1.43/images/create?tag=0.4.3&fromImage=homeassistant%2Famd64-addon-zwave_js&platform=linux%2Famd64: Internal Server Error (“Get “”: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”)

(this error is specific to the Z-wave js addon, but I got an error similar to this with all other addons).
Since this did not work, I reset jobs with “ha reset jobs”

I found a post where someone suggested to run the command “ha network info.” I did that, and have found that “host_internet: false” and “supervisor_internet: false.” And they suggested to change “host_internet” to true, but I don’t know how to do that. They also suggested running the command “ha reload network” but I just got a time out error which was “context deadline exceeded (Client.Timeout exceeded while awaiting headers).”

Checking out the logs, it appears lots of other services are being prevented from getting through.
I tried restarting supervisor; again, no change.

To iterate the question: If i have a static IP assigned to my HA installation at the router level, is it crucial that I have the the HA network IPv4 settings set to static?


I have HA set to DHCP, and have assigned a DHCP reservation in my router. I’ve used that under several iterations with no Internet issues. When I changed HA from docker to HAOS on RPi, and then migrated to HyperV VM on windows, then to HAOS on NUC, each time I just updated DHCP reservations. So I recommend that approach, but have no idea what is going on with your installation :frowning:

1 Like

This is helpful and encouraging! Thanks!