Accessing my public HA endpoint (via Duck DNS) only works intermittently

I’ve been on HA for about two years now, and have consistently dealt with this issue. When I access my instance from my local network in a browser, it works fine. However, when I access it via my publicly facing (via DuckDNS) endpoint, it’s a coin flip whether the page loads. Actually probably worse than a coin flip because I’d say it’s less than a quarter of the time I get the page to load.

It’s annoying when you’re trying to browse your HA install, but it’s a showstopper when it comes to certain integrations that need to be able to access my endpoint publicly.

There seems to be no rhyme or reason either: it will work flawlessly for certain stretches of time and then fail to load for several minutes.

Any ideas?

DuckDNS seems not be as reliable as it used to be. See discussion here

thanks. that may be the case, but the behavior I’ve seen has been consistent for two years now, which tells me it’s something other than some potential recent degradation with the Duck DNS service.

It might be someting between you and DuckDns. I would humbly suggest it generally wouldn’t at the same time work for some folks and not for others if their configuration is the same. I have been using it for about 1 1/2 years now, and except for only a couple of day about 2 weeks ago, it has been flawless for me. When I am on my local network I even just use the URL then as well so that I would immediately know if something was wrong. My internet access from within my local network is through a randomly rotating set of 10 VPN tunnels in different non-14 eyes locations (set up on my router connecting as client to server through two different VPN service providers) and it still works. Maybe it is a different situtation for people in different countries (although as I mentioned from moment to moment I can be coming from one of several different non 14-eyes countries). Seems like there is not enough information to the root cause of the issue… Possibly an intermittent port forwarding issue? How do you connect from outside to your HA - just port forwarding or also through a VPN (I am just port forwarding at the router level with a 30 digit password but will add a server VPN on my router (as it is just acting as a client to those VPN providers) at some point…)? Have you tried a trace route or other investigation?

I found a bunch of other forum posts (going back over a year) that describe precisely what I’m seeing. So I switched to Cloudflare tunnels and it’s working perfectly.

2 questions

First. What could duckdns actually do that would make a site intermittent. Does it actually need to respond for each dns request for the domain with your WAN IP?

Technically if duckdns is issue why not just connect direct to yourwanip:8123 as initial test? If this is problematic as well duckdns is not issue but if it is definitely duckdns.

Second. If duckdns is issue maybe get your own domain through cloudflare maybe. $10usd/yr not small but may be worth it in the end. Not sure
Your contry but in US dynamic domain is basically static and remain same unless disconnect more than 24hrs. I’ve had 3 IP in 14+ years, one because i moved.

Even with this, I never hear of domain related issues so i’m ignorant of this error and still expect problem to be unrelated to duckdns (but admittedly ignorant of these issue).

That’s exactly what I did, I just bought a domain from Cloudflare and used their tunnel service.

Accessing my IP directly always worked, just going through Duck DNS was problematic.

I honestly cannot figure out the difficulties people have with duckdns. I’ve been using it for over 2 years without so much as a single issue…

Cloudflare is not an option if you use video streaming (eg. IP cams), at least for the basic service because it violates their T&C’s.

got it! good to know, however I don’t have any high-bandwidth use cases like that.

Do you talk about a Cloudflare tunnel or Cloudflare Dynamic DNS ?

I was reading that the Cloudflare Stream service is required to do this. The free service does not allow this.