Actions through today widget not working

Does someone know if there has been a change in the way “actions” Work in the companion app?
For some time nothing happens when triggering an action through the today widget.
Nothing seems to happen when subscribing to “ios.action_fired” on the Events page when I trigger an action.
This has worked fine before.

I have the same issue. I did update to iOS 13 though, did you @jeppper? I’m using the 2.0 beta companion app.

I am also on Companion 2.0 but not updated to iOS 13 yet.
I guess it maybe happened after a update of HA?

Same issue here. I’m on iOS13 and companion 2.0 and Hass.io 99.3. It used to work, so not sure where it stopped. Don’t see any activity when listening to ios.action_fired events.

Just noticed this a few days ago, i stopped today to debug, there are no events neither today actions or siri shortcuts.

Any solution to this yet?

I have just installed the new 2.0 HA companion app and latest Hass.io (102.2) This is not working for me, either via home screen quick action (3D press on HA app icon) or the today widget.

My automations are ok as they work when manually triggered. I’ve triple checked the action name and trigger text are identical.

How can you troubleshoot e.g. listen to ios.action_fired?

You need to enable developer tools then in there it’s at the bottom of the events page

My Today Widget actions have now started working after switching to the final 2.0 app release.

Thanks @TomBrien that solved my problem. Each of my actions had an extra space in them at the end of the text that wasn’t visible in the app. All I had to do was go into the app (still wasn’t visible!) and delete the space - all good and working now!

Great work. That’s the kind of thing a spend days trying to spot

I can’t get this to work from the Today View but can get it to work from some parts of the app icon 3D touch menu:

- id: ios_action_arm
  alias: iOS Action Arm
  initial_state: true
  trigger:
    - platform: event
      event_type: ios.action_fired
      event_data:
        actionName: 'Arm'
  action:
    service: script.alarm_arm_instant

- id: ios_action_disarm
  alias: iOS Action Disarm
  initial_state: true
  trigger:
    - platform: event
      event_type: ios.action_fired
      event_data:
        actionName: 'Disarm'
  action:
    service: script.alarm_disarm

I have this same automation working and far as I can tell my only difference is that I don’t use the single quotes around the actionName.

You can have a look at my yaml here: https://github.com/olbjan/home-assistant/blob/81f6fd311bea02cb662aa3e854f2815cf1059df7/packages/ios.yaml

I removed the quotes and reloaded automations but it made no difference. ’

It actually feels like a problem at the phone end as I receive double haptic feedback pulses when attempting to press the icons.

Interestingly the way you’re describing open the app but the widget doesn’t. Is that the behaviour you see? Is background data allowed? Check iOS settings>Home Assistant

Ok I’ve just confirmed this is a bug. App shortcut is passing the text as actionName whereas widget correctly uses Name field

1 Like

That may be a bug but it’s probably not my bug. Both strings are identical in my actions.

In developer tools can you listen to ios.action_fired then try both buttons and see what you get

Where do I find / enable developer tools?

Oh you mean in home assistant.

Hang on.

I don’t see any events. Even when it actually arms the alarm using the 3d touch text menu.

Ok that’s weird. Are you using a separate pc to listen or the app?