Activate Z-Wave fails after upgrade

Yesterday I upgraded my Raspberry 3 as suggested. I’ve also upgraded the OS, because the interface suggested these.

Now I have the following versions:
Supervisor: supervisor-2021.01.5
Core: core-2021.1.4
Host: Home Assistant OS 5.10

My Razberry 2 Z-wave-controller GPIO module won’t start after that. Everything worked before the upgrade.

I’ve checked that the configuration in configuration.yaml is still there:
usb_path: /dev/ttyAMA0 (that’s the device that is presented under Supervisor/System/Host/Hardware)

The OZW-log shows the following:
2021-01-18 20:31:37.772 Always, OpenZwave Version 1.4.3469 Starting Up
2021-01-18 20:31:45.640 Info, Setting Up Provided Network Key for Secure Communications
2021-01-18 20:31:45.640 Warning, Failed - Network Key Not Set
2021-01-18 20:31:45.640 Info, mgr, Added driver for controller /dev/ttyAMA0
2021-01-18 20:31:45.641 Info, Opening controller /dev/ttyAMA0
2021-01-18 20:31:45.641 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2021-01-18 20:31:45.641 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2021-01-18 20:31:45.642 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-01-18 20:31:45.642 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2021-01-18 20:31:45.642 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2021-01-18 20:31:45.642 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2021-01-18 20:31:45.642 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2021-01-18 20:31:45.642 Detail,
2021-01-18 20:31:45.642 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-01-18 20:31:45.642 Detail, contrlr, Notification: DriverFailed

After that I opened the config.txt and realized that the following line is missing (which was there before I updated hassio): dtoverlay=pi3-miniuart-bt

Added that line again and started HomeAssistant, but still got the same error in the log and Z-wave does not start.

Give this a quick try:

remove the zwave addon…restart HA…install the zwave addon again and configure:

/dev/serial/by-id/usb-0658_0200-if00 instead of /dev/ttyAMA0

That solution worked for me!
Thanks for the tip.

Other question: I have added an addditional Fibaro Dimmer 2. But I can’t seem to get it added to the network.
tried : 1. press add node in HA and press the button on the dimmer until the light is blue. the button on the dimmer until the light is blue and then press add node in HA.
Took off the Live wire, waited a few minutes and connected it again…

Any suggestion?

FWIW, I had the same problem and the solution was to reboot HA and unplug, then re-plug in the USB stick and Z-Wave popped right back up again.

Sorry for the late response, but it did not work for me. Modified as suggested and removed OpenZwave Version 1.4.3469 (which seems to be added automatically on reboot)
When I go to Supervisor/System/Host and open Hardware, I only see /dev/ttyAMA0 and not /dev/serial/by-id/ usb-0658_0200-if00, even though I switched to it in configuration.yaml

Nice that it worked for you. I have a Razberry connected via GPIO connector, so I have no USB I can unplug and put back :frowning:

If you see ttyAMA and not the serial that probably means somehow Bluetooth is (re)activated. Just a thought

I have always used /dev/ttyAMA0. It was after upgrading Core that I also updated Supervisor and Host that the problems occurred.
When I opened config.txt, the line dtoverlay = pi3-miniuart-bt was gone (which I added when installing my Razberry on the circuit board). Did put it back, but it did not help.

The problem is that I do not remember which versions I had on Supervisor and Host. Have tried downgrading to 5.8 on Host, to see if it helped.