Activate Z-Wave fails - DriverFailed

Tags: #<Tag:0x00007f739a2bc108>

I have home assistant running on a raspberry pi 4.
System: HassOS 3.7
Version: 193

I added the Aeotec Gen5 Z-wave stick.

Then I added Z-Wave under integrations.
And added the following to my configuration.yaml:

zwave:
  usb_path: /dev/ttyAMA0

When I go to my Z-wave settings I see this:

When I click “Start network” it doesn’t start. And this is the OZW log:

2020-01-03 11:59:20.413 Always, OpenZwave Version 1.4.3452 Starting Up
2020-01-03 11:59:41.941 Info, Setting Up Provided Network Key for Secure Communications
2020-01-03 11:59:41.942 Info, mgr,     Added driver for controller /dev/ttyAMA0
2020-01-03 11:59:41.942 Info,   Opening controller /dev/ttyAMA0
2020-01-03 11:59:41.942 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2020-01-03 11:59:41.942 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2020-01-03 11:59:41.943 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2020-01-03 11:59:41.943 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2020-01-03 11:59:41.943 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2020-01-03 11:59:41.943 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2020-01-03 11:59:41.943 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2020-01-03 11:59:41.943 Detail,
2020-01-03 11:59:41.943 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2020-01-03 11:59:41.943 Detail, contrlr, Notification: DriverFailed

Does anyone has an idea what the problem is?

Find a cheap or old usb hub, and use that then it would work.

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=245031#p1502030

2 Likes

I have to search for one but I will definitely try

You don’t need to have both.
It’s a bit “easier” to save network key if using configuration.yaml. I’m not sure where you can look what kind of key the integration part creates.

Personally using from the integrations menu.

I have exactly same problem. Any ideas?

Your answer is here from post 2. :slight_smile:

I haven’t found a hub so I ordered one. Will give an update when it arrives.

Now it’s tested with usb hub and still same situation - Driver Failed
To be sure, I created new clean HassOS 3.8 install and tried adding Aeotec,
exactly same result.
When I test Aeotec stick on PC with Zensys Tools, it’s working - I can add nodes,
but with HA it refuses to start

Make sure the /dev/tty is correct

This will never be the path for a USB Z-stick. Use /dev/ttyACM0 or preferably, since this is a Aeotec, use /dev/serial/by-id/usb-0658_0200-if00.

I connect only Aeotec stick to Pi4
Under Hass.io > SYSTEM > HARDWARE I see only: /dev/ttyAMA0
I added Z-Wave under integrations with this and it reports Success

If you are getting Notification: DriverFailed that wouldn’t be a success tho.

Thank you so much!
With /dev/serial/by-id/usb-0658_0200-if00 my Z-wave started working :slight_smile:
From where you took this address?

For other people looking for the answer to this question, you can find the serial address on HassIo by using the ha hardware info command and the address is in the serial section;

serial:
- /dev/ttyAMA0
- /dev/ttyACM0
- /dev/serial/by-id/usb-0658_0200-if00