Add a Broadlink device located in a secondary home as part of primary Home Assistant place

Hello Everyone!

I have started to setup my first Home Assistant environment. Although I think I will use a dedicated Raspberry Pi sooner or later, I am using a Synology NAS + Docker at the moment. So far, everything is running ok. On top of the straight out of the box integrations, I have managed to learn codes from a Broadlink HUB to control my rolling shutters, which is tedious but works. At the end of the day, once this learning task is fully done, I believe I won’t have to do it again. My HA instance is accessible from out of home as I am using a dynamic dns hostname.

However, one thing I have not been able to achieve is to control another Broadlink HUB that I have in another location (different network; different public IP address). I have tried to add an additional integration with host:port format, assuming that I could reach the Broadlink HUB using a dynamic dns hostname and a NAT virtual port redirection (external port 5454 and internal port 80), but an Invalid hostname or IP address error is given. It seems a port cannot be specified when adding an integration. Any advice on how to do this?


long term, Maybe put in feature request to allow Port change from default for broadlink integration/allow define port for broadlink

short term, maybe add a second RasPi w/HA at other location and either control seperatly, use mqtt or use HA API(my preference) to control remote device. Depending on use case this may work better as it will allow control on local network

Thank you! For the moment, I have sorted it out setting Broadlink IP as DMZ in the router. I know that is not as secure as it should be, but I don’t have any computer or server in such location, so it’s fine for me. However, noted your suggestion for setting up a RasPi in the future. Cheers!

Greetings sesardelaisla

Can you please explain how to configure the settings step by step, I need to do like whaat you did to connect the broadlink pro from second home to my HA in first my first home. I use Zerotier to connect my HA remotely.

Hi there! It’s been a long time from the moment I setup this. I eventually moved to the place I used to connect remotely to. But, as far as I remember, I did the following:

  1. Setup the remote WAN router with a DDNS option in order to be able to use a hostname which always is updated with your WAN IP.
  2. Fix your BroadLink HUB LAN IP with the option that your remote router should have on the DCHP menu (link HUB MAC address to a chosen free LAN IP so the router always assigns the same LAN IP).
  3. Enable the DMZ option of your remote router and setup HUB IP as DMZ host. From this point, all incoming requests will arrive to the BroadLink HUB regardless of the port.
  4. In Home Assistant, add the BroadLink integration and type the DDNS host you enabled in the first step into the “host” field. The integration should see the remote HUB and you should be good to move forward from there. Hope it helps!

Anyway, have you tried to setup a port in the integration? After one year, perhaps the integration has already been updated and it now works if you specify a port together with the hostname.