Add Aqara (v3 hub) sensors to Home Assistent

Tags: #<Tag:0x00007f3274853cb8>

HI, I’m a bit confused because a lot op topics about Aqara v3 hubs appears to be old and not right anymore. Also the documentation only mentions the v1 and v2 hubs.

Obviously the v3 model (the one with RGP light & speaker) is the homekit model and seems te be supported as well by HA. Connection was pretty straightforward. It was actually found automatically and the only thing was to add the homekit code that was printed on the back of the hub.

Next, I added on temperature/humidity sensor to the HUB via the Xiaomi app and made sure it works.

It was not showing up immediately in HA but after a while it did and the temp & humidity worked. (I was playing around with various setting for other purposes, so I don’t know if i triggered some manual required action).

Next, the 2nd temperature sensor! Again, added to the Xiaomi app and make sure it works. An now…wait…and wait. Restart HA, rebooted the HUB, but no 2nd sensor in HA…

At the same time I also renamed the first sensor in the Xiaomi app to the non-default one to give it a more meaning full name however the old name is still in HA.

My questions,

How to add sensors to HA, as the official docs only refers to V1 and V2 and all forum topics are about non-working sensor types (that most seems to work at this time of writing). As the first worked automatically (or I did something unintentionally) I’m believe others should be auto-detected as well? Or is some manual config required?

Q2: If names are changed in the Xiaomi app, do they automatically change in HA as well?

Tried to reconnect the Xiaomi HUB to HA by first removing it.
After reload of HA I would expect the auto-discovery to find the HomeKit enabled device again (Aqara HUB), just like the first time. However, it doesn’t find anything anymore.

Why did it work the first time?
Is some manual action required to pair the hub to HA?

Strange, hub will not re-appear in HA.

So next step is to pair again with the Xiaomi App and when that was working the HUB was detected again by HA (took some time I believe). After this reconnection all connected child devices (2x temperature, 1x door sensor) were immediately added to HA. :slight_smile:

However, the main question remains, how to update HA after something has changes in the Xiaomi app?
Or is this just the procedure for Aqara Hub v3 as homekit accessoire?

Added antoher sensor today via the app and it’s working fine. However the new sensor will not show up in HA again.

I’m searching everywere but it’s very confusing with so many different hub type.
This is the v3 awara homekit model.

How to add devices?
I doubt that the only way is to revome the gateway and re-add it again?

I believe that is the only way. I can’t see to find a way to have the hub attached to the app and Home Assistant at the same time. Which app are you using? How did you manage to get the Hub to be present in the app?

I’m using the Xiaomi Home app.
The hub is attached to the app and new devices can be added via the app as normal.

The hub was also discovered by HA but it will only discover the devices that were connected at that time. Devices connected afterwards are not discovered anymore by HA.

I can’t find a way to manually force a re-discover other than removing the entire hub from HA and the APP and reconnect everything.

Pretty sure re-adding to HA is the only method.

Update to HA 0.110.4 today and a previously added Aqara vibration sensor to the Xiaomi app now suddenly appeared in HA. I don’t know if any of the fixes contributed to this or the update proces itself but it picked up the sensor by itself.

I have another new sensor still in packaging so I can try if auto-add will work right now.

hi, i’m new in Home Assistant.
i’ve tried to add aqara hub v3 via homekit controller integration with no success.
“device can’t be found”

Hub is connected to mi home app.

i’m using vmdk version on wmware.
Is it possible to add hub? What’s wrong?

Strange, since later releases this should all work automatically.
I had some issues but it was more to connect it to the APP. (switch region to China, connecting using 2,4 Ghz wifi).
Once connected I only provided a static DHCP lease but unsure if this is required.

Then, after HA reboot (?) the HUB was found as HomeKit device automatically, did not require any searching. It asks then for the homekit pairing code that is on the back of the HUB, next to a QR code.

I’m not familiar with the wmware setup but I could imagine there could be some networking/discovering issues.

i’ve tried vmware for testing purposes. i’m planning move it on rasberry PI.
I have know no idea about discovery issues but ping woks.

Is there any way to get power consumtion data from mijia zeegbe plugs or should i forget about using homekit integration and look at zigbee2mqtt?

anyone able to get the motion sensor to also show as illumination sensor?