Add devices via router on Z2M

Tags: #<Tag:0x00007fc3f12746a8>

Hi All,

A noob question here, is there any way to add devices via router instead of the coordinator? I see that on the UI of Z2M, there is a drop down for permit join(All). I tried selecting other router, but it doesn’t seem to work. Is there any configuration needed for this to work?

I m currently using a raspberry pi4 with cc2531 as my coordinator. I m currently close on “max-ing” out my coordinator device limit. I have been trying to re-position the end devices closer to my router, in hope they “ditch” their direct route/connection to the coordinator. Some worked, some don’t. I know cc2531 isn’t the best coordinator, but I m left with little choice since its the one that is readily available online., i would like to stick to z2m.

I the following devices that act as a router.

1 x cc2531 flashed with router firmware
1 x ikea repeater
1 x sonoff zbmini
5 x sonoff basiczbr3
3 x tuya powered led controller.

I believe that the above should be sufficient to bring me well pass 100 devices in total (if i m able to pair them ‘efficiently’ to the closest router instead of the coordinator). Please correct me if my understanding is wrong.

Thanks in advance

Hello! When you try to enable join in Zigbee2Mqtt webpage, does it not accepting new devices when you put it near your router?

Make sure you already press the button on the end device to enable pairing mode.

Hi, Thanks for the quick response. Yep, the devices are in pairing mode. I m unable to pair them when i place the devices next to the router but it works when i place it next to the coordinator.

I see.

According to the developer of zigbee2mqtt, Koenkk, he said “What you could try is re-pairing the device not directly close to the router, but at a little distance, where it’s still in range of the router, but not in range of the coordinator.” Statement said here.

However, I wouldn’t worry too much about the need to pair to the router. You can just try pairing it with the coordinator, then place it in the place that you want. The Zigbee mesh should work itself out to find the best routing possible (maybe through the router).

The problem is that i m at the limit of cc2531, i m stuck, i cant add more devices without freeing ‘space’ on the coordinator.

On the opening post, you said you are “close” to maxing out your coordinator limit - it suggests there are some rooms left.

Therefore, you could try pair it with the coordinator, then place it somewhere where the coordinator cannot reach the device - but still in the range of your router. Hopefully the Zigbee mesh can re-route it through your router.

Hi Ardysusilo, Thanks for your response, i tried to squeeze more than the coordinator can handle. And my understanding of more than 100+devices is wrong. CC2531 has a limit of 40 devices. Obviously when i m close on maxing out the coordinator. I am indeed on its limit.

That topic says: max 40 Zigbee 3.0 devices. It depends if you still have Zigbee 1.2 devices.

Hmmm… i am still pretty new to the entire smart home stuff. I m assuming the items i bought recently are all ZigBee 3.0 stuff…