Add Fibaro Roller Shutter 3 node to Zwave JS

Hi everyone.

I’have recently purchase multiple Fibaro Roller Shutter 3 (FGS-223) to automate my shutters. I made the wiring according to the documentation but my problems started when I tried to integrate it into home assistant.

First problem, the “Add node”… It requires to push fastly 3 times the S1 button but in my case, i’have a Schneider command with 3 button (UP, DOWN and Stop). I finally solved my problem with the special button on the FGS-223.

Once the device is connected to “home assistant”, i try to close my shutter with HASSIO but i have an error message : “service call failure cover/open_cover None.”.

I thought it could come from the calibration that I had not done. However, probably impossible to launch the calibration for the same reason as the “add node” problem. I’have tried to launch it with 5s S1 or S2 push but nothing help.

So, anyone wil be able to explain me:

  • How to calibrate my FGS-223 ?
  • How to fix my problem of “service call failure cover/open_cover None.” ?

(I use Hassio with aeotec stick, and zwavejs server directly with the supervisor addon).

I thank you in advance for your help, I am starting to go crazy with this problem :stuck_out_tongue_winking_eye:

Hi razor620,

after migration to zwave js same problems here.

The UP/DOWN and Stop buttons give the same error message. As an intermediate solution I work with set_position.

I still have one old Fibaro Rollershutter 2, this worked right away in the new ZWAVE integration.

In the ZWAVE 1.4 integration you could set the parameters in the configuration (e.g. Calibration). However, I could not find anything in zwave js.

Since zwave js is still very new, I hope that there will be a solution soon.

I solve one of my problems !

I found a solution for the calibration : press 5s “B” button waiting white light then fast push again the B button. However it doesn’t solve the “service call failure cover/open_cover None.” :disappointed_relieved:

After the last update it works !

So, for the calibration, press 5s B until the white light is on the another press on B, and for the “service call failure cover/open_cover None.” Upgrade just HA.

1 Like

Hi there,
still having the problem to add the fibaro roller shutter 3.
I’m running the latest stable version of hassio core-2021.2.2 and I’ve freshly installed z-wave js with addon. Adding my fibaro dimmer 2 worked out of the box, but when i try to add the roller shutter, the entities, which are responsible for the movement of the cover ,are not detected and i get several error messages in the log. In the deprecated z-wave integration i also got two devices adding the roller shutter, what is not the case with the new one. Hope you give me a hint how you managed to get them work.

I’ve had some trouble to add my shutter the first because zwavejs seam to freeze. So for all my shutter i 've the same step:
1- add node and start inclusion in HA zwave js integration
2- push 3 time the “b” button behind the fibaro roller shutter 3
3- then i begin the calibration : press “b” until the white light then 1 more hit fast after the white light
4- then i try to close cover from ha : most of the time it failed…so i reboot ha
5- after the reboot i have 2 entities “current value”. I disable the second (_2) and i use the first one and it works !


I’m new on Hass.
Firstly, i tried with ZWave (deprecated) but it does not works. So, i’m trying with ZwaveJS.
I created a topic : Fibaro Rollet Shutter 3 - Calibration does not work

Fibaro Roller Shutter 3 (FGR23 v5.1) is well recognized on Hass with ZWaveJS. (note: I’ve tried razor620’s solution a dozen times to make it work)
But, Node status id : dead
Node Ready: No

If i click on the switch, Node status does not changed.
I can not add automatisation or script : “No automation is available for this device.”

What do I need to do to control my roller shutter from hass ?
This module will drive me crazy :face_with_symbols_over_mouth:

EDIT: Add logs

20:51:27.317 CNTRLR   [Node 003] The node is now alive.
20:51:27.319 CNTRLR   [Node 003] Beginning interview - last completed stage: NodeInfo
20:51:27.324 CNTRLR   [Node 003] ManufacturerSpecificCC: doing a partial interview...
20:51:27.331 CNTRLR   [Node 003] VersionCC: doing a complete interview...
20:51:27.331 CNTRLR » [Node 003] querying node versions...
20:51:27.355 CNTRLR   Failed to execute controller command after 1/3 attempts. Scheduling next try i
                      n 100 ms.
20:51:34.424 CNTRLR « [Node 003] received response for node versions:
                        library type:      Enhanced Slave (0x03)
                        protocol version:  6.2
                        firmware versions: 5.1, 5.1
                        hardware version:  3
20:51:34.424 CNTRLR » [Node 003] querying CC versions...
20:51:34.425 CNTRLR   [Node 003]   skipping query for Application Status (0x22) because max implemen
                      ted version is 0
20:51:34.426 CNTRLR » [Node 003]   querying the CC version for Multilevel Switch...
20:51:41.449 CNTRLR   [Node 003] did not respond after 1/3 attempts. Scheduling next try in 500 ms.
20:51:46.992 CNTRLR   [Node 003] did not respond after 2/3 attempts. Scheduling next try in 500 ms.
20:51:52.534 CNTRLR   [Node 003] Node 3 did not respond after 3 attempts, it is presumed dead
20:51:52.537 CNTRLR   [Node 003] The node is now dead.
20:51:52.544 CNTRLR   [Node 003] Interview attempt (9/5) failed, node is dead.


  • Raspberry Pi 4B 4Go
  • Home Assistant 2021.2.3 installed on SSD
  • Aeotec Z-Stick Gen5+
    zwavejs version

Hi there!
Is there any requirement to add the Fibaro RS to HA via Z-Wave JS and Aeotec 5?
I just unpair it successfully from smartthings but i cannot pair it with HA…tryied 20 times and nothing.
Even reset the fibaro to default and nothing.
Is there any advice or trick?