Add Google Home account issue

After download Google Home module from HACS and restart HA. I try to setup google home. it pops up google home authentication page with account account username (yes I knew). google account app password (yes. I can go to google account webpage, login to create it). Google account master token. Don’t know where to get it. tried to go to HA user profile long-lived access tokens and create one. It doesn’t work. Where can I get this master tokens?

2 Likes

I am also facing the same issue. Any idea on how to generate a master token?

Did you ever figure this out? I’m struggling with the same problem.

I solved this issue by following

basically

  1. sign in Google security account to create app password for HA
  2. in Windows PC, install docker engine for win11 (not docker desktop). it will install ubuntu.
  3. in ubuntu, following leikoilja instruction to get image and run commands. (if using GUI interface, no luck)

I ran the generation script in every possible way and it’s not working. Super frustrating. If someone figures out a reliable way to get it done I’m all ears. I read some comments about the process not working with passkeys active.

all current solution need to be run at Linux text screen that can mount docker. If you try running from docker GUI or inside of docker, it doesn’t work. That took me a lot of time to figure out.

sorry could you expand a bit on this? What does it mean exactly?

I am windows man. In Microsoft Windows OS, the bottom base is Windows OS, if you need load a docker on it. you need install the environment, that is Linux (2nd layer) and then docker (3rd layer). Finally you can load some docker image. On the web you can find installation that create GUI to make easy. However, after installation, you are on 3rd layer docker environment already. It will be a problem. You need using the solution instruction in 2nd Layer (linux environment).

1 Like