“Add Integration“ Pop-Up Spins Indefinitely

For some reason over the last few weeks (timing unclear, since I don’t log into HA very often), whenever I go to Settings → Integrations and click “Add Integration” in the lower right corner, the “Select Brand” pop-up appears but none of the integrations actually appear. Instead, I see a spinner under the search box that never stops spinning. I can type into the search box, but it doesn’t do anything.

I’ve waited up to 5 minutes to confirm nothing appears, but in the past there was no wait at all, the list of integrations would just appear immediately.

If I exit and flip over to the logs, this is what I see:

Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘ConnectTimeoutError(<urllib3.connection.HTTPConnection object at 0x7f40d516fa60>, ‘Connection to 192.168.1.120 timed out. (connect timeout=3.0)’)’: /setup.xml

10:35:58 AM – (WARNING) /usr/local/lib/python3.10/site-packages/urllib3/connectionpool.py - message first occurred at 10:24:42 AM and shows up 22 times

http://192.168.1.128:8123/frontend_latest/b7c20564.js:300:10578 TypeError: Object.entries requires that input parameter not be null or undefined

10:33:06 AM – (ERROR) components/system_log/init.py

[139916481856176] Error handling message: Unknown error (unknown_error)

10:30:44 AM – (ERROR) Home Assistant WebSocket API - message first occurred at 10:27:45 AM and shows up 2 times

I tried to search the forums since this seems like it must be something basic I messed up, but I’m not sure what’s causing it (and can’t seem to find anyone else with the same issue).

For what it’s worth, HA seems to work just fine, including my existing integrations, I just can’t add any new ones (which is obviously not ideal).

Thank you!

Update: I checked again, and it looks like the only thing appearing in the logs when I tried is this:

Logger: homeassistant.components.websocket_api.http.connection
Source: loader.py:287
Integration: Home Assistant WebSocket API ([documentation](https://www.home-assistant.io/integrations/websocket_api), [issues](https://github.com/home-assistant/home-assistant/issues?q=is%3Aissue+is%3Aopen+label%3A%22integration%3A+websocket_api%22))
First occurred: 11:58:43 AM (1 occurrences)
Last logged: 11:58:43 AM

[139916105930912] Error handling message: Unknown error (unknown_error)

Traceback (most recent call last):
    File "/usr/src/homeassistant/homeassistant/components/websocket_api/decorators.py", line 27, in _handle_async_response await func(hass, connection, msg)
    File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 755, in handle_integration_descriptions connection.send_result(msg["id"], await async_get_integration_descriptions(hass))
    File "/usr/src/homeassistant/homeassistant/loader.py", line 287, in async_get_integration_descriptions custom_flows[integration.integration_type][integration.domain] = metadata KeyError: 'service'

Does anyone know what I can/should do to resolve this? I’m basically at a dead stop adding anything new to HA right now and I don’t know where to look next :frowning:

Thank you!