"Add matter device" unavailable

Followed the directions. Flashed ESP32-C3 and obtained BLE onboardingcode. Using Android companion, in Settings, Devices & Services, I select Devices and “Add Device”. “Add Matter Device” is not an option. Bluetooth is active on the phone.

Suggestions, please?

1 Like

Matter server addon and matter integration

Yes. Both look OK to me. Still no “Add Matter Device.”

The same on my iPhone.
Home Assistant 2023.2.5
Matter server 3.1.0 is running.
Still no “Add Matter Device”

Now on Core 2023.3.0 and Matter 4.0.0. Integration says use companion app. Companion still does not have Add Matter Device. Glad I won’t depend on this for quite some time.

But, cleared cache of companion app and updated to 4.1.0 Matter add-on. Now "Add Matter Device’ is available.

BUT, BUT when I click it I’m told “Matter is currently unavailable”. I’ll say! The add-on is running and claims to be listening.

Log entry:
Config entry ‘Matter’ for matter integration not ready yet: Failed to connect to matter server; Retrying in background. Good luck!

Deleted Google Home from Android phone, then reisntalled it from Play Store. Now can add matter device. Successfully flashed Lighting App for [ESP32-C3-DevKitM-1]. BUT, after entering manual code and waiting for “Connecting device to Home Assistant …” got “Can’t find device.”

Have progressed to “Not a Matter-certified device” for ESP32-C3 running example Matter app. Added entries in Google Home Console per instructions, but no change (“Not a Matter-certified device”).

Same problem, after flashing esp32, using companion app to add the device I get “not a matter certified device” error message

I think one way around it is to create a Google Project Matter test device with corresponding Vendor ID or something like that…

Tried that, but no change.

Huh, mind sharing how you registered your test device (steps, Vendor ID, etc) ?

ybarigou, read this, especially the note for Android users (me), which refers to the link above it.

This is really confusing.

See above, make sure your device meets all requirements to support Matter. Update Android to the latest version and the Google Home and Home Assistant Companion app. To quickly verify if your device meets all requirements to support Matter, on your Android device go to Settings >Google >Devices & Sharing . There should be an entry there for Matter devices .

I have an updated android device and do not see a Matter entry in Google devices. Do we need any other hardware to make sure Google->devices shows a Matter entry?

They aren’t talking about the Matter Device entry being in the Google Home app; it should be in the smartphone/tablet Settings>Google>Devices & Sharing.

Yes and its not there. But they preface with saying Google Home app needs to be installed. Sorry I will correct my original question.

I uninstalled Google Home several times to solve "Matter is currently unavailable” problem, but nothing changed.

Just wondering what we need to do to make sure Matter shows up in Devices & Sharing.

Unless I am reading this wrong, it says we need a Google Hub to enable Matter devices. What?

Note : If you don’t have a hub, you might be able to add your Matter-enabled device to the Google Home app, but you can’t control it.

“You might” is not very reassuring.

Others having the same issue.

1 Like

Both of my Motorola Z series phones (one Z2 play and a Z4) have it showing, but not my Samsung Galaxy phone.

I can share what I have found so far.

  1. On my Samsung S21, “Matter Devices” is under “Settings/Google/Devices and Sharing”. It appears Matter is under Google Services, and I’m guessing that “Smart Things”, “Google Home”, and the HA App all use the same Google Service for Matter setup.

  2. Selecting “Matter Devices” takes me to a screen that says I have zero linked Matter devices, and a “+ Connect New Device”

  3. The New Device process allows me to scan the QR code on my Tapo P125M, recognizes it as a Matter Devices, tries to communicate with it, and it fails every time.

I have only been able to add the P125M to the Tapo app, which does not use the Google service as far as I can tell.

Strikes me as no laughing matter. ;-}

1 Like

Ok follow up on this. I have no idea why these feels so random, but I uninstalled Google Home App, rebooted, still no "Matter devices " showing.

BUT, I just rebooted again for shits and giggles, and now it is showing. So freaking strange. I hope they fix this. I will file a bug with them.

Have you tried reinstalling Google Home? Someone pointed out that HA companion didn’t actually have a matter enabling. It instead uses’s android’s or apple’s integration to enable them. There were several of us who had these issue resolved by simple reinstall! Let me know how it goes!

This appears to be related to:

It looks like an issue with Android and the Google home app. If you don’t have the matter option in Settings->Google->Devices then you will get the “matter is unavailable” error. It appears that uninstalling and reinstalling the app gets this option back but it will disappear randomly after a while. I’m guessing there isn’t much that home assistant can do to fix this…

I had hard time being able to add Kasa matter plug into Home assistant.

I solved it by

  • Send the plug in paring mode by holding the off button for 10 seconds
  • Directly add it to Google Home ( I did not have any problem while adding to Google Home)
  • Open the settings of the added device and copy the newly generated matter code.
  • Most important, when adding into home assistant Click add matter → More option → My Accessory isn’t Shown Here → Enter code past the newly generated code. This was the only approach that worked and I was able to add the Kasa matter plug.
  • Once t

I ended up changing the Thread Border router from Aqara M3 to skyconnect and none of the companion apps are syncing the thread credentials when I tried from HA App → Settings → Companion App → troubleshooting → Sync Thread credentials,

As mentioned in https://youtu.be/rEugjMk-4II?t=5655 I ended up clearing the storage of Google play services. From then onwards, My phone (samsung S23 ultra) complains that Matter is not available. It is same on samsung Note 9.
On google home app, it shows add a matter device, but nothing happens when I click on it and it lands back on devices tab.

I opened my phone camera for a different purpose and accidentally scanned a matter QR code which was lying on my desk. It then updated play service and everything is working.

So the key point what I understood here is, clearing the play services storage clears both matter and Thread related stuff. For thread we can resync fro Home assistant companion app. For matter scanning a QR will update play services.

This is just my experience and it might not be the same for everyone.
Note: clearing the play service storage will delete lot’s of stuff. I have exported my chrome passwords before clearing. I had to repair my waerable as a new watch.