Add-on: Dynu DNS (alternative to DuckDNS)

I’ve been using this instead of DuckDNS for about a year, but every month or so I need to restart it to be able to connect to my Home Assistant. Anyone else know a way to restart this like once a week?

Can this one be installed together with duckdns? So if one is down. The other will still do the job as dnsprovider? Or will this cause conflicts?
I think I ask before I break.

I just wanted to say thank you @koying, this addon saved me a lot of headaches!

I was banging my head on the wall for one week now, when i was trying to access HA remotely through the app or through web browser (Android, Windows, MacOS), sometimes the connection goes through once and after that i was unable to connect to it, i was receiving notifications but on connect i was getting web socket error or just blank screen and was unable to connect from nowhere! Hours after i was able to connect again only once or twice.

I tried everything and i mean everything and the last thing on my mind was that the duckdns was unstable, i thought my Mikrotik router rules or debian or HA was the problem and finaly after lot of forum reading i stumbled upon your God send post and Addon :innocent:

Thank you!

2 Likes

You can try and make automation to restart the Addon periodicaly, maybe that will fix the problem i had the same problem with duckdns addon but i didnt tried to make automation because i have other remote connection to my server and restarted the addon localy

Cannot thank you enough @koying for this add-on!

After weeks of constant lack of connection externally to my HA and days of troubleshooting, testing, guessing etc - I finally narrowed it down to being an issue on my mobile/cellular network (O2, UK). Further reading shows that O2 constantly bans DuckDNS domains and IPs due to malware, hacking etc. So if anyone gets to here from the UK and is on O2 - duckdns is blacklisted by O2, so your app and external access won’t work while you are on your mobile data connection…

A quick google finds me here with a near 99% copy of DuckDNS & LetsEncrypt add-on. Set this add-on up using Dynu, and even re-configured my NGINX Reverse SSL add-on - and all things working perfect again - I can now access my HA instance via SSL and 443 traffic over my NGINX proxy, on mobile network!

Be sure to setup your Dynu add-on as per the documentation, turn off DuckDNS and stop if from starting again, update your NGINX add-on config, and also Settings->System->Network, and replace any “duckdns” domains you have seto to the new Dynu one.

Thanks again!!!

2 Likes

Hey @chunkysteveo, man i am in the same boat as you deleted my docker containers many times i am tunning swag container and i thought it was to do with that messed many of my setups when i was on mobile data on o2 and couldnt connect to HA.

Finally realised it is o2 messing around. And now i am here.

I see you have suggested to use this add on but can you please tell me if i can run it on a docker container?

Many thanks man.

1 Like

All addons are docker containers :wink:
If you know docker, it’s trivial to run an addon as a “plain” docker container:

1 Like

Works like a charm. Thank you for creating this addon!

Yes, using my new add-on

Hi! I’m trying to use this addon. I’ve one little problem: the ipv6 is not detected.
The curl command is not working from inside the docker of the addon:

curl -s -f -m 10 "https://ipv6.text.wtfismyip.com/"
curl: (7) Failed to connect to ipv6.text.wtfismyip.com port 443 after 3 ms: Couldn't connect to server

But if I execute the same command in the bash of the Home Assistant, it works. I suppose this does not work because the IPv6 must be attached to the container, and this docker does not have one. But if it has one, it will not work neither, because it will be different than the IPv6 of the Home Assistant docker, that is what we want.

Looking at the DuckDNS addon, I see this code:

That I suppose that tries to obtain the ipv6 from host interface.

Hi. I have been using your add-on for couple days for dynu and duskdns and its working great, I just add algo: secp384r1 in LE yaml for myduckdns to works,
thanks for your contribution…

Thanks for working on this Addon, works very well!

How do i setup subdomains like server.test.dynu.org?
With DuckDNS it was just adding a new entry in Nginx proxy hosts. This seems not to work with Dynu. :man_shrugging:

@koying

I created an account here just to say thank you. Like others in this thread I live in the UK. I have just started using Home Assistant to see if I like it. I am happy to pay for could services and do everything properly, but just want to do a self demo first.

I work with computers building servers etc. But I spent 2 days banging my head off the desk trying to get duckdns working. I could access my external url from my home pc via htpps, but was trying to test true external access from my mobile. It was another users post in the thread that mentioned about O2 (I am with giffgaff on o2’s network).

So I just set up your method and no issues at all. Now able to access my HA externally. Thank you so much for your time in setting this up!

1 Like

Cant connect after 3 months, i get ( The date of the Home Assistant certficate is invalid, please review the Home Assistant or the connection settings and try again. When i start stop the service i get that the cert is valid till June 11… what im doing wrong?

I’m also getting Invalid certificate errors.
I don’t see a certificate in DynuDNS at all. I believe this add-on is broken.

Hi I can’t renew ip in case of router disconnection. I have to restart home assintant… Solutions?

Tired of DuckDNS issues, I’m trying to install Dynu DNS Add-on, but I get this error during the installation:

The command ‘/bin/ash -o pipefail -c apk add --no-cache openssl && curl -s -o /usr/bin/dehydrated “https://raw.githubusercontent.com/lukas2511/dehydrated/v${DEHYDRATED_VERSION}/dehydrated” && chmod a+x /usr/bin/dehydrated’ returned a non-zero code: 1

Any hint?

Thank you in advance

I forgot to add that I’m with Home Assistant Core 2024.6.4

I have exactly the same issue on a fresh installation of home assistant core, I searched for some solution but nothing worked so far. Duck dns gets installed without any issue