Add-on: Dynu DNS (alternative to DuckDNS)

As DuckDNS is a bit shaky recently, I created an alternative add-on using the Dynu DNS provider, which ranks as amongst the best free dynamic DNS providers around as far as I could see.
It has a bit more variety as far as the root domains available, which is nice.

The addon is at 99% a copy of the duckdns addon.

Disclaimer:
I don’t use the add-on myself. My “main” HA is not even on HassOS, tbh.
This is a “gift” to the community, and an exercise for myself.

About

Dynu DNS is a free service that points a DNS to an IP of your choice. This add-on includes support for Let’s Encrypt and automatically creates and renews your certificates. You need to sign up for a Dynu DNS account before using this add-on.

Installation

  1. Navigate in your Home Assistant frontend to SupervisorAdd-on Store.
  2. Click 3-dots menu at upper right > Repositories and add this repository URL: https://github.com/koying/ha-addons
  3. Scroll down the page to find the new repository “Add-ons from Koying”, and click one of the new add-ons.
  4. Click Install and give it a few minutes to finish downloading.
  5. Configure at Configuration tab or separate file in Configuration folder according to the instructions of the add-on.
  6. Click Start, give it a few dozen seconds to spin up.
  7. Enjoy.

Issues?

Open a ticket at the github repository

Thanks for this!, I use Dynu and installed the LetsEncrypt add-on and then found it is not one of the supported DNS providers, this is just what I needed, will give it a try…

I tried duckDNS and it was highly unstable. This works perfectly! thank you

I have been using Dynu for years now for my entire network of subdomains and it was amazing service. its a shame that entire HA community is endorsing duckdns as the configuration options on Dynu are even wider.

Now I have one question, the duckDNS addon is taking care of the letsencrypt generaiton as well is it part of this one too ?

Yes, it does

I uses Let’s Encrycpt in Nginx proxy so it’s as disabled on Dynu DNS AddOn.
But I have a problem to run Dyny DNS updater for my domain.

Idea to solve this?

No clue. Just tried with letsencrypt disabled and it worked fine for me.

Hmm… Ok, I have to try to debug the script or write one more alternative. :smiley:

It seems to be Dynu problem. IP update for another domain works. I made the support ticket for Dynu about this.

Hi,

I just tried to install this and seems my subdomain IP isnt updating. I see the bellow in addon log:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] done.
[services.d] starting services
[services.d] done.
INFO: Using main config file /data/workdir/config
Account already registered!
[cmd] /run.sh exited 1
[cont-finish.d] executing container finish scripts…
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

and one line in HA logs:
2022-02-15 16:32:28 ERROR (MainThread) [homeassistant.components.hassio] Failed to to call /addons/4e8751bd_dynudns/stats - Container addon_4e8751bd_dynudns is not running

Any ideas?

Well the container is not runing. Try restarting the addon from the supervisor. if it still show the same error it may mean that you either run out of space or something else is colliding with that container.